Templates Plugins Courses

400 Bad Request Error with 'Upload File A File Upload No GUI' Action in AWS File Uploader Plugin

I am encountering an internal error when using the ‘Upload File A File Upload No GUI’ action in the AWS File Uploader Plugin. I receive a 400 error when attempting to PUT an image to AWS. However, when I use the Instant upload feature of the FileUploadNoGUI Element, the upload works without any issues.

I’ve checked the demo but couldn’t find any part that uses the ‘Upload File A File Upload No GUI’ action. Could you please check the plugin for this issue?

Also, the images I’m trying to upload with the ‘Upload File A File Upload No GUI’ action are set to ‘Everyone can view’, so I believe Bubble’s privacy rules should not be affecting this.

image

Hello @y_ksmt1,

Thank you for contacting us!

I’ve conducted some initial tests and encountered the same error message in the console, yet the file successfully uploaded to the S3 Bucket. Rest assured, I’ll pass this information to our development team for further investigation.

To better assist you, could you please share your specific use case? This will help me recommend an effective temporary solution.

It’s important to note that the actions you described are intended for file uploads via URLs. This means you can use the URL of a file uploaded to Bubble for this process. As for the “Instant Upload” feature, it is operational with the ‘begin upload’ action. This implies that if you select a file for upload in the NoGUI element with “instant upload” disabled, the ‘begin upload’ action is required to initiate the upload to your bucket

Wishing you a wonderful day ahead :hugs:

Thank you for the prompt response :pray:

I tried once again, but unfortunately, I still cannot get the upload to work correctly in my environment. It seems there might be an issue with how my workflow is configured. I am attaching screenshots of the relevant screens.

What I am aiming to do is upload a file internally upon a button click.

I would greatly appreciate your continued support on this matter. Thank you in advance!



image

Hi @y_ksmt1,

You do not require the “Begin Upload” action into the workflow. I have explained the usecase for this action in my message above :pray:

After uploading the image to your AWS, please ignore the error message you are getting. However, could you please doublecheck your bucket and see if the image was uploaded? I have also gotten the exact same error you have said above, but the image was uploaded successfully.

Please rest assured, we’ve initiated an investigation into this error, and our developer will be working on a fix. I’ll be sure to inform you once the update is confirmed and live.

Cheers :hibiscus:

Thanks for the advice. :pray:

There was a problem with the AWS configuration.
The error I was getting internally when going to PUT the image was “AccesControlListNotSupported”.
So in order to use the “Upload File FileUploadNoGUI” action, I had to be the owner of the object in AWS and have ACLs enabled.

If I enable Instant Upload and Begin upload, it did not seem necessary to enable this setting.

Hello @y_ksmt1,

Just to clarify, if you enable “Instant Upload” for the NoGUI element and upload the file by “Begin Upload” action, the error is no longer present?

Cheers :hugs:

@dorel

It seems my explanation was unclear, my apologies. :pray: I had no issues with the “Instant Upload” and “Begin Upload” actions of the NoGUI element. These functions are working correctly and there wasn’t a need to enable ACL.

The problem is with “Upload File FileUploadNoGUI” action. In this case, I receive two errors. One is ‘AccessControlListNotSupportedThe bucket does not allow ACLs’ and the other is ‘AuthorizationHeaderMalformedThe authorization header is malformed; the region ‘us-east-1’ is wrong; expecting ‘ap-northeast-3’’.

The first error resolves when I enable ACL in AWS, but the region-related error persists. Regarding what you’ve mentioned, “I’ve conducted some initial tests and encountered the same error message in the console, yet the file successfully uploaded to the S3 Bucket,” it might be related to the region error you are encountering.

There might be a part in the plugin’s “Upload File FileUploadNoGUI” action definition that hardcodes the region as ‘us-east-1’ during authentication.

image
By the way, while we are on the subject, what is the difference between “File uploader” and “File uploader new”?

Hi @y_ksmt1,

Thanks for providing more details!

I’ll be sure to look into this as I test the new version of the plugin and discuss this behavior with the developer. Rest assured, I’ll get back to you with more information as soon as possible :pray:.

Regarding the “new” file uploader you mentioned, it’s possible that it appeared during an update or when the developer was implementing fixes to the plugin. Could you please specify which version of the plugin includes this element?

Best regards :hibiscus:

image
I am using the latest version. :slightly_smiling_face:

Also, let me ask one more question. :pray:
Are there any restrictions on “Max Files” settings? How many max files can I specify? I checked the manual but could not find out.

image

Thank you in advance.

Hello @y_ksmt1,

The “new” element was added unintentionally during a marketing update, and we failed to confirm that the developers were not actively working on it. In version 1.164.0, this element has been removed. Please disregard it. :pray:

Regarding the “Max files” field, there technically isn’t a limit. However, the higher you set this field, the more likely performance may decrease. If you prefer not to have a limit, you can leave this field blank.

Best regards :hibiscus:

1 Like

Hi @y_ksmt1,

We’re thrilled to inform you about the latest update for the AWS File Uploader plugin - version 1.165.0. This version includes several improvements for both the GUI and NoGUI elements, including the “upload file/files” actions. I’ve conducted tests on these actions, and I’m pleased to report that the “400 Bad Request” error no longer appears in the console.

To update the plugin, navigate to the “Plugins” tab in your Bubble editor, select the AWS plugin, and choose the latest version from the dropdown menu.

Once updated, could you please test it on your page and let us know your thoughts?

Wishing you a fantastic day ahead! :hibiscus: