Templates Plugins Courses

Adminy template - permissions


#1

I purchased the adminy template. The template came with a lot of pages and several things did not show up in the documentation, but I spent a few hours and got it to work on a new app instance. After looking at it, I wanted to take this template and integrate it into my existing app.

I copied from the adminy app to myApp

Reusable objects
Data Types
Pages with work flow

I then went through the 1400 issues that popped up one by one. A large number were styles that did not come across so I copied and pasted those.

I then fixed all the dialog and pop up references that were lost in the copy/paste

So now I have a couple of issues I would like to understand how to fix:

  1. The permissions are set as per the instructions in the documentation but I can not add subpages via the admin interface, nor do the high level folders and users (that I just created) show up in the admin_navbar

I have copied the data entries in the permissions data type from the adminy database to the myApp database and I have added each of those permissions to the group I am using as superadmin. I followed all the steps in the documentation to set up preferences but fear i have missed something or don’t understand.

  1. I still show about 60+ issues, mostly that say the same thing. See attached. When I look at the working adminy template, it looks identical. The adminy template does not have data passed back to the admin template from workflows, but myApp is throwing an error because that data source is empty.

Any insight to either of these issues and I would have this up and running moving it from the template into an existing app, which seems like a daunting task, but 8 hours in I am almost there.

Thanks

Craig


#2

I believe I have solved some of permissions problem, I had to manually enter the Group-View Permissions for the Admin page. I don’t however understand why I can enter pages, but not sub-pages? I don’t see a subpages add in the permissions on the Adminy db.

If someone has insight into the Data to send issue going to the admin page, that would be most helpful.


#3

I have also discovered i can not update this page:


#4

The Privacy settings do not come with a table when you copy and paste them from one app to another, so you have to reset those, that solved the problem on the last item.


#5

I am not sure why, but I added a Group-View-Permissions entry for my user and then the system updated it with the pages from the workflow. Working! :slight_smile:


#6

Sorry, Craig, that we were not as fast to send you the solution as you to find it yourself :slight_smile: But glad you managed it!