Templates Plugins Courses

Advanced Custom Dropdown Conditional Issues

Hello.
I’m in need of some urgent assistance to get an application out to production. This is my second try at solving this issue, which led me to your custom dropdown. When using the Custom Dropdown plugin, all things work as advertised except when a conditional is added. It is fundamental to all other entries in the form that this dropdown should have the same conditional as it indicates a successful entry.

Example of no issues making a selection when there is no conditional set on the element:
https://screenrec.com/share/qUf7VlBoCv

Example of the issue when the conditional is set on the element. It does not matter which conditional, it always happens.
https://screenrec.com/share/RiOH1Xog8c

You will not that the first selection away from the placeholder does not “take”. If you select it again, it will accept the selection and display changes from placeholder text to the selected item. It you select another option, it will work as well (no double select). However, if you go back to “No selection” (placeholder) the same issue will happen. You will have to select something twice to make a successful selection. Obviously, this is not workable with in the real world.

The only difference between the two scenarios is the addition of the conditional to the element. No other changes made. It can be one or multiple conditionals, the issue remains present and the same.

Appearance:

Conditional (for failure scenario):
image

Can you please have a look at this and give some feedback. I hope this is an easy fix so you can release a fix rapidly.

@zerocode - Can someone please have a look at this item and provide some feedback?

Hello @avr

Thank you for reporting the issue.

We will definitely investigate the issue and try to fix it as soon as possible. Once I have any news regarding the investigation I’ll get back to you.

Regards,

Thanks for the patience @avr

We have fixed the issue with the conditionals for the advanced custom drop-down menu, please update to Version: 1.19.0, and let me know if everything works well :slight_smile:

Have a great weekend!