Templates Plugins Courses

Advanced Multi Uploader with Azure

Hi There - just purchased Advanced multi uploader

I’ve gone and set it up following the azure instructions here Multi-Uploader Plugin When I try to upload a file it fails

I can hit the folder using Azure file explorer (and upload files) so not sure what im missing. Are there more detailed instructions to follow? I just want to drop files in there to start with then will move onto workflows and securing the folders.

All I do now is drop a file in and hit the upload icon in the plugin, it fails after a few seconds (time varies with file size)

Thanks in advance.
John

Hello, @john3
Thanks for reporting your issue.

In order to understand an exact issue, can you please share more details with us?
I need to see your plugin’s settings and also, description of the exact error you facing during file uploading.
Please send me screenshots of the error from your browser console :pray:

Right now, there are no errors on our side, so I suppose that it’s related to your settings.

Right now, all the steps could be found only in official plugin’s documentation. However, we are always open to help our user’s with that.

I’m looking to hearing from you soon.
Best regards,

Hello @Ecaterina

I am having same issue. Here is my console snapshot


and following the link gives this message

Pls advise

Hello, @sangotechnology1
Thanks for reporting your issue.

Please make sure that you are using the latest version of the plugin.
Also, you filled in one of these fields:

I need to see how exactly is configured the plugin element and how you are using it in your app.
Please provide me with more details about your settings, so I will be able to replicate them on my side.

I’m looking to hearing from you soon.
Best regards,

Here is my setting

My workflow

Hello, @sangotechnology1
Thanks for the screen.

I suppose that the issue is related to your keys for Azure Storage.
Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

I am looking to hear you soon.
Regards,

Hello, @sangotechnology1
Thanks for providing the access to your app.

As I can see from your app, after testing the file uploading, the main issue - is CORS policies.
image

Please make sure that you have enabled all these checkboxes, as it was demonstrated in our documentation:

It seems like not all required options are enabled on your side.

I am looking to hearing from you soon.
Best regards,

I have all that set up done correctly.
Here is a screen shot of my azure dashboard

Hey, @sangotechnology1

In your Azure account, please check these settings too:

Find the CORS settings and put the allowed methods, as in my screenshot. After it, please add * to Allowed origins, Allowed Headers, and Exposed Headers.

I suppose that this should help with this error.
Please check it and let me know about the result.

Best regards,

Hi Ecaterina,

I have made the change as directed but now have the new error show below

Here is my Azure network settings also, to mke sure firewalls are not enabled

Hello, @sangotechnology1

I’ve just tested your application, and I need to note that the root cause of the issue is in your expired key.

Here, you need to indicate at least one year, and not a few days:

Thus, please change the Start and Expiry date\time, and generate a new key. After it, don’t forget to put an updated key in the plugin element.

I am looking to hearing from you soon.
Best regards,