Templates Plugins Courses

Agora shows unknown error log

Hello there.

I’m sharing this because I got a mysterious error message and was told to tell the management.

To make it a native app, we were trying to eliminate screen transitions and move to rooms on the same page.

If you try to function a room on the Group object without screen transition, the following error messages will be displayed and the room will not function properly.

1, Entering the room does not work. Audio is not output in the first place.
2, I try to enter the room again, but Mute all video, which is supposed to work automatically when entering the room in the workflow, does not work.
3, When I move to the room with screen transition and try to enter the room, it works fine.

If you could be so kind as to share how to fix this, I would be very grateful.

Hi @wors.biz, thanks for reaching out.

To be able to help you, please provide as many details as possible. Namely:

  • screenshots and/or screencasts of your setup - workflows, plugin settings (for the screencast recording, let me please suggest using the Loom tool).
  • screenshots and/or screencast of the issue you have (debugger, browser console, etc);
  • steps to reproduce your issue;

This will allow us to identify the issue faster.

Looking forward to your reply.

Regards,

Dear @wors.biz, also, allow me to mention that considering that you are trying to make a native app, you should take into consideration that the Bubble platform and plugins are mostly developed for web app use.
We do not guarantee that their usage into a native app might result in errors and incompatibility issues.

Thank you for understanding.

Regards,

1 Like

Hello Serg.

Thank you for your reply.

We are understanding building a native app is might be a rare and unsupported way of building, but here are the descriptions.

Steps to reproduce the problem

・Put Agora in a Group in the same screen, and display the Group when the workflow “Move to another page” is performed. An error message is displayed when this happens.

・The workflow is set up so that the video is turned off by default when a screen transition is made.
For some reason, this does not work correctly. and I’m reporting it as a possible bug.

・Since this is a voice service, we want to turn off video by default. So I set up a workflow that turns off the video once every 5 seconds. But it still doesn’t turn off the video.

★By the way, if they move to another page that is not within the same screen, but to a different address (e.g. /menu→/room), agora works fine.

We would be much appreciated if you kindly dealing with these multiple issues.

https://drive.google.com/file/d/1rHwVF7GiRCABDIPeqVgZF4ATiMh0tiXz/view?usp=sharing
Buggy situation. As described above, when we trying to move to the room, it happens.

https://drive.google.com/file/d/1PAAb0r8lmVnZq1YWzIkas-E0ybj_FnKC/view?usp=sharing
eg) When we trying to move to the room without move on the same page it’s fine.


It shows the entire workflow and page structures include the plugin itself. For some reason, it didn’t show the error message.

Regards,

Dear @wors.biz, sorry for the delayed reply (due to the weekend).
Allow us to analyze the provided information and come back with a reply in due course.
Thank you for understanding.

Regards,

Dear @wors.biz,

We’ve analyzed the provided information and need to say that the current Agora connector element functionality is not allowing the implementation of the logic described above. Sorry for the inconvenience.
Only one Agora plugin element per page is allowed because a unique access token for each room is created based on the current user ID, so the second created token for the same page will not be unique already.

We tried to reproduce this on our side, but didn’t succeed, the video is muted as it should. We presume this bug also might be related to the issue with tokens, mentioned above.

What we can recommend:
1st of all, open a new Agora connector’s room on the new page, as this is a correct scenario.
2nd of all, please check if the turning off the video feature will be functioning well on the newly opened page (as per the above suggestion).
3nd of all, it is a friendly suggestion (optional) - simplify your workflows. You have a great number of actions under a single event. It might make it harder for the app to perform some actions, even can influent some plugin’s work.

Sorry for not having the best solution for your case.

Regards,

Hello, Serg,

Thank you for your dealing with this issue
and we are apologized for replying late.

We could understand the cause of this issue would come from a token or something. We would investigate tokens and able to use them as not native app but web app at first.

And also as our app’s workflow little complex, therefore we’d simplify and try to test again.

Regards,

1 Like

Hi @wors.biz, no worries.
In case if any other plugin related issues will appear, you know where to find us :slight_smile:

Thank you and have a nice day!

Regards,

1 Like