Templates Plugins Courses

Algolia Search - Failed to show field

Hello, @tifanirose1611.

For the Text part.
It was a limit to restrict users to only work with this type for a reason that plugin returns one type and works fine with the Algolia implementation and we wouldn’t know what kind of objects users do return and sometimes is confusing for many.

However, we now removed the restriction for Data Type so you could give it a try. Please upgrade to the newest version, refresh the page.

Thanks for understanding.

I’m experiencing the exact same thing where it appears I have everything setup properly but the search is only returning the Algolia objectID.

Hello.

We’ll look into the issue encountered, meanwhile I would recommend to take a look at the setup https://bubble.is/page?type=page&name=algolia_search&id=zeroqode-demo-11&tab=tabs-1 and documentation one more time: https://docs.zeroqode.com/plugins/algolia-search-plugin
Maybe you missed a step in configuring the algolia side dashboard, which is quite sensitive to lowercasing text.

Thanks for understanding, we’ll be back to you asap.

Hi @Dumitru
thanks for your quick response.
I have seen your last update about restriction data type and re-install the plugin, but it still failed to returning the field. I guess one of the problem is the match plural parts that didn’t work / clickable.

How about your alternative offer for adding you as collaborator to our app and take a look there? If you don’t mind we will invite you soon.
Thanks

Hi Tifani.

yes, please add our developers: plugins@zeroqode.com to the app so we could debug it. Also pinpoint to the page location where the issue is.
Thanks.

I finally got the fields to display. I need to create a search for all users on my app. The issue I was having is the fields wouldn’t display when I had the Data Type of “Agolia Search A” set to User (default by Bubble). So, it appears the plugin doesn’t function with the default user type. Any thoughts? @Dumitru @levon

Hi @rgnldbrks
Do you setup something in your work flow to fixed it? If you don’t mind could you explain the way that you get? It will really helpful for me

Thanks anyway

Hi @tifanirose1611, I’m assuming it started to work for me because I changed the Data Type. I was trying to create a search that would search all my apps users. I created a new data type and it started working. I hope that makes sense. It doesn’t look like you are using “user” as your data type so I’m not sure why it’s not working for you.

Try leaving all the column choices blank and preview the app. See if you get an error message. Also, what field type is “name_warga”? (text or user)

Hi @rgnldbrks,
thanks for your answer. I haven’t try it but will do soon, since your input about Data Type look make sense for me, because that “nama_warga” is a text Data Type.
Keep give any update if you have.

Thanks anyway.

Hi @Dumitru
I have added your developers account to my app. Have you take a look to my app and found problem with the plugin? Waiting for any update from you so I can immediately use this plugin.

Thanks.

Hello, @tifanirose1611.

We’re still looking into more critical issues with other plugins, however we’re moving on and soon the devs should look at your app.
Thanks for understanding.

Hi, @tifanirose1611.

Sorry for the delay. We are moving with plugins and now we can look at your app.
Our dev tries to debug it, however he needs some details regarding Algolia Dashboard of your setup.
Could you please provide a screenshot of the Index from Algolia which is used in your app?
Thanks for understanding.

Hi @Dumitru
sorry for late response.
Here are my algolia index.

Thanks

Hi @tifanirose1611.

We looked into your app’s setup and Algolia setup. So the recommendation which come from the dev team, is that you avoid using the numbers in both places. Seems like that’s why objectID field returns, is the only result you got.
Hope this helps.

Regards,
ZQ Team.

Hi @tifanirose1611, @Dumitru

I’m currently facing the same issue with my app. Did avoiding numbers in both places fix your issue?

I don’t use numbers in any of my setup. Did you find anything else that prevents the “objectID” from displaying?

Thank you for your help,

Best,
Remo

@Dumitru I’m also facing the same issues. I’ve set up Algolia exactly as the documentation outlines, and followed the live example on Bubble.

I can get the search to display the field ID, but not the name, or any other field type. Is this a bug, or is there any solution to this @Dumitru?

Hello everyone.

Internally we worked on Algolia and with @jeremiah 's app we tested the latest version of Algolia with his permission and collaboration.
We pushed an update to Algolia plugin now it is easier to match the data fields by manually writing them in the new Manual Fields where simply write your Algolia index fields for searching. No need to create database in Bubble to match the one in Algolia.

See the app we tested it and now it gives the results which match Algolia index:

So everyone who has trouble: @tifanirose1611 @remo.rohner please upgrade to the latest version of plugin refresh the app and give it a try.
In due time we’ll improve the documentation and couple more features as well so that users will get an ease of use experience.

Regards,
ZQ Team.

@Dumitru sorry one last quick question- I have the updated plugin, but don’t see the “Manual Fields” entry that you screenshotted above. Is that coming later?

Please check the latest version of the plugin, try removing it and installing again may be a Bubble hiccup here.
We pushed the update and tested in your app as well which shows the results as you saw the screenshots.

The new feature is available now and is under the Data Type option:

Best,
ZQ Team.

Hi @Dumitru,
I’ve updated my plugin version, try that manual fields, but still failed for showing text results. I think I’ve been followed your instruction but still get failed. Could you please check up my app too? I’ll add you again.
Thanks