Templates Plugins Courses

Algolia Search - Failed to show field


#1

Hi @levon
Need your help…
I just used your Algolia Search plugin, follow your tutorial in your plugin docs and your demo page but i got a bit problem as you see below,

when searching began, it success to preview correct data in RG (compare with my index in Algolia) but just displaying ‘objectID’ and failed to display ‘name’ field even though I guess I’ve set-up correctly.

Here my index i’ve been created in Algolia

And here in bubble





picture7

Hope you can help!
Thanks,
Rose


#2

Hello, Rose.

Sorry for the trouble, but have have you tried also adding in bubble configuration the matching of the given words for plurals. Seems like you missed it.
Also maybe try re-install the plugin, since the config from the screens seems like it’s the right way to go.

Otherwise, we’ll look into the issue and offer an update on the matter asap.
Thanks for understanding.

Regards,
Zeroqode Team.


#3

Hi Dumitru,
thanks for your response.

fyi, i can’t clicked the match plurals parts. It’s like a disabled input. Is it trouble from your plugins or any thing missing from me?
And what should i do for re-install? should i unsubscribe and then re-subs again?

Thanks,
Rose


#4

Hi, Rose.

Yes, by uninstalling I meant the process of unsubscribing and subscribing back to plugin. It shouldn’t break anything, and try again. Also make sure to use the latest version of plugin.
Hope this helps.

Alternatively, if you could add our developers as collaborator to your app and pinpoint the page location of issue, so we could troubleshoot it. Add [email protected] account.

Thanks for understanding.


#5

Hi @Dumitru
just another question
Could you explain about Data Type part, what are the limits of the fields displayed by the plugin (in column input)? because I found that just 1 fields of 10 fields I have that can be selected and that field known with field type ‘text’. Is that the limit?

Do you have a solution for this one?

Thanks


#6

Hello, @tifanirose1611.

For the Text part.
It was a limit to restrict users to only work with this type for a reason that plugin returns one type and works fine with the Algolia implementation and we wouldn’t know what kind of objects users do return and sometimes is confusing for many.

However, we now removed the restriction for Data Type so you could give it a try. Please upgrade to the newest version, refresh the page.

Thanks for understanding.


#7

I’m experiencing the exact same thing where it appears I have everything setup properly but the search is only returning the Algolia objectID.


#8

Hello.

We’ll look into the issue encountered, meanwhile I would recommend to take a look at the setup https://bubble.is/page?type=page&name=algolia_search&id=zeroqode-demo-11&tab=tabs-1 and documentation one more time: https://docs.zeroqode.com/plugins/algolia-search-plugin
Maybe you missed a step in configuring the algolia side dashboard, which is quite sensitive to lowercasing text.

Thanks for understanding, we’ll be back to you asap.


#9

Hi @Dumitru
thanks for your quick response.
I have seen your last update about restriction data type and re-install the plugin, but it still failed to returning the field. I guess one of the problem is the match plural parts that didn’t work / clickable.

How about your alternative offer for adding you as collaborator to our app and take a look there? If you don’t mind we will invite you soon.
Thanks


#10

Hi Tifani.

yes, please add our developers: [email protected] to the app so we could debug it. Also pinpoint to the page location where the issue is.
Thanks.


#11

I finally got the fields to display. I need to create a search for all users on my app. The issue I was having is the fields wouldn’t display when I had the Data Type of “Agolia Search A” set to User (default by Bubble). So, it appears the plugin doesn’t function with the default user type. Any thoughts? @Dumitru @levon


#12

Hi @rgnldbrks
Do you setup something in your work flow to fixed it? If you don’t mind could you explain the way that you get? It will really helpful for me

Thanks anyway


#13

Hi @tifanirose1611, I’m assuming it started to work for me because I changed the Data Type. I was trying to create a search that would search all my apps users. I created a new data type and it started working. I hope that makes sense. It doesn’t look like you are using “user” as your data type so I’m not sure why it’s not working for you.

Try leaving all the column choices blank and preview the app. See if you get an error message. Also, what field type is “name_warga”? (text or user)


#14

Hi @rgnldbrks,
thanks for your answer. I haven’t try it but will do soon, since your input about Data Type look make sense for me, because that “nama_warga” is a text Data Type.
Keep give any update if you have.

Thanks anyway.


#15

Hi @Dumitru
I have added your developers account to my app. Have you take a look to my app and found problem with the plugin? Waiting for any update from you so I can immediately use this plugin.

Thanks.


#16

Hello, @tifanirose1611.

We’re still looking into more critical issues with other plugins, however we’re moving on and soon the devs should look at your app.
Thanks for understanding.


#17

Hi, @tifanirose1611.

Sorry for the delay. We are moving with plugins and now we can look at your app.
Our dev tries to debug it, however he needs some details regarding Algolia Dashboard of your setup.
Could you please provide a screenshot of the Index from Algolia which is used in your app?
Thanks for understanding.


#18

Hi @Dumitru
sorry for late response.
Here are my algolia index.

Thanks


#19

Hi @tifanirose1611.

We looked into your app’s setup and Algolia setup. So the recommendation which come from the dev team, is that you avoid using the numbers in both places. Seems like that’s why objectID field returns, is the only result you got.
Hope this helps.

Regards,
ZQ Team.


#20

Hi @tifanirose1611, @Dumitru

I’m currently facing the same issue with my app. Did avoiding numbers in both places fix your issue?

I don’t use numbers in any of my setup. Did you find anything else that prevents the “objectID” from displaying?

Thank you for your help,

Best,
Remo