Templates Plugins Courses

Apple signin working on some phones and not on others

Hello

I keep having problems with Sign in with Apple.

On some phones it works, on other (mine) it does not work.

By clicking on the button nothing happens. I used to have this problem in the past: once a sign in was aborted it didn’t react for a few days but then at some random point it started working again. In my case now it’s not working since weeks now. I updated and reloaded the phone several times meanwhile.

On others it works fine.

T$hanks

update:

I just tried your setup
https://zeroqode-demo-20.bubbleapps.io/signin_with_apple

and it doesn’t work either on my phone… Is there a specific setting on iOS that prevents login?

Hello, @floripaolo
Thanks for reaching out :slight_smile:

Actually, no. I can ensure you that our Demo Page is working properly. I’ve just tested it with iPhone 13, iPhone 11, and iPhone 8, with different iOS versions.
It is possible that sometimes, you don’t get a response from the Apple platform, but it is entirely related to the Apple platform’s performance.
Sometimes, it could even happen on massive platforms like Amazon, eBay and etc.

In case it doesn’t work only on your phone, I’m afraid it’s not the plugin’s fault.
Please make sure that you do not use any blockers and that you do not have any limits on different types of applications.
We didn’t receive any complaints from the users regarding this plugin behavior, so I suppose it is something related to your mobile device.

Best regards,

Ok. Thanks.
If you say that everything works fine…

1 Like

@floripaolo

In case I can help you - just let me know.

Best regards,

1 Like

something else:

there is no way to edit the style of the element (besides color and language). Correct?

Hey, @floripaolo

It is not possible, to follow the Apple platform policies. In case you are using this button, it should look only that way (you can see that on different platforms).

Best regards,

Well I’m fact there are many different layouts out there…

Vbb


Hello, @floripaolo

Depending on the platform, the system provides up to three options for the appearance of the Sign in with Apple button: white, white with an outline, and black.
On Bubble, we are using a black button.

Best regards,

Well. Apparently it’s not just on my phone (and on some of our test phones). We tried on Testflight with the submitted app version on iOS16.1.1

Apple just rejected our app because the login button is not reacting on their test iPad.

I also tried to login into your demo page for Apple login.

On the same phone there is no reaction on Chrome and it works fine with Safari.

Hello, @floripaolo
I’m sorry to hear that.

I would like to advise you to check your responsive design for iPad, since it is possible, that the button is overlapped with other elements or groups for exactly these dimensions :pray:

Please find below my screencasts from the iPhone 13 Pro ( 16.1.1. OS version) from both Chrome and Safari browsers.
By the way, as you can see, entire process of signing in and redirecting back takes 34 and 21 seconds ( not as long as it was stated earlier).

Loom | Free Screen & Video Recording Software | Loom
Loom | Free Screen & Video Recording Software | Loom

Best regards,

Hello
Responsive design for iPad is correct. And as i said several times in the last 8 months: it happens on iPhones as well. If it was an overlapping problem this would not happen on the exact iPhone model where it works.

I never said that it takes 1 minute (that was ZQ support on Bubble Forum stating this is acceptable). I said it takes up to 20 seconds. Nevertheless: Nowadays nobody waits for 20 seconds in front of a blank screen. I am afraid.

@floripaolo

I’m sorry about that, but I have tested your application earlier and never faced this issue on any testing device (laptop, iPhone, iPad).
Can you please let me know where I can download your app and test it too?
I really interested in helping you, so I want to test different scenarios.

I need to note that this forum thread on Bubble is also leaded by me, so I replied to you.
In case we will be able to decrease waiting time - I will let you know.

Best regards,

Hello @Ecaterina

We have some phones where it works without problems others where it works intermittently and some where it doesn’t work at all.
My phone worked fine for several months. Now it doesn’t work at all since weeks.
This morning for instance it started the login process for the first time in weeks, Face Id scanned, but then aborted the process and the app opened the signin popup again without signing in. I tried again but no reaction as the last few weeks.
As I mentioned before it doesn’t work in native app and Chrome browser. But works fine in Safari.
Same behaviour as on your Demo page for the plugin.

App Store:

Google Play:

Cheers

Paolo

Hello, @floripaolo
Please allow me to add some highlights here:

As for your native application, unfortunately, we can’t fix it for you. Please allow us to highlight that all our products (both templates and plugins) are web products firstly, so they work properly in web applications. There is no guarantee that any plugin will work in the native application ( especially with foreign services).
For this reason, the strange behavior of the plugin on some devices could be reproduced by incompatibility.

From this message, I can understand that issue is not with the plugin, but with devices. I don’t mean that they are incorrect, but they are exactly the error’s root cause.
As I demonstrated to you in my previous messages and in our previous communication, I was not able to reproduce this issue ( on the web version of your application), and every time and from any device, the plugin worked correctly and I was signed in on our Demo Page, and your Application.

We downloaded your application on 4 different devices (iPhone 13 Pro, iPhone 11 x2, and iPhone 7).
For 3 devices, we were able to sign in with Apple. However, on one device we were able to reproduce your issue.
After some research, we defined the issue.

Please note that the latest iOS version is really buggy and there are a lot of complaints regarding different functions ( we are facing troubles every day right now). One of the reasons, that could be related to your issues, is the AssistiveTouch button: iOS 16 update triggered AssistiveTouch issue, but there's a fix.

While waiting for the official patch, there is a potential workaround that might solve the issue. Basically, all you need to do is toggle the AssistiveTouch feature on/off.
“Settings” → “Accessibility” → “Touch” → “Assistive Touch” and then turn it on again.

In our case it was helpful.
Please try it and let me know about the result.

Best regards,

There is no need to fix it. Since I use BDK everything works fine. (Besides your plugin :slight_smile: )

  1. It was working erratically with ZQs native service as well.
  2. As I said Apple login doesn’t work in Chrome browser on my phone, whereas it works on Safari (both are web browsers)

As you could reproduce yourself, it works on some phones and doesn’t on others. Coming to a quick conclusion by this, that it must be a device problem is not exactly what I would call debugging.

BTW: Assistive touch on/off toggle didn’t change behaviour. With iOS 15 the same issues were present.

I guess bottom line is: we just had bad luck that this time around Apples review device is one of the ones that don’t work.

@floripaolo

In your previous message you noted this:

Thus, we decided to download your application to different devices in order to test it. However, I’m happy that it is working well on your side. :slight_smile:

We reproduced this behavior with your native application, which was downloaded from Apple Store. But after toggling Assistive touch, we were able to sign in.

Just now, I tested your web version of the app on Chrome (the latest version of the browser). Please find here a screen record, where, as you can see, we are not encountering the same issue.
https://www.loom.com/share/877ca1293c034b00aeb6219e612c637d

Can you please add my team to the list of collaborators to your application? I would like to discuss this behaviour with our Development team in order to debug the issue.

Best regards,

Once again: It has nothing to do with native. It doesn’t work on Chrome either. Your own Zeroqode demo page does not work on Chrome. The fact that you cannot reproduce it doesn’t mean much. It still doesn’t work on other phones.
I know that not being able to reproduce a bug is a developers nightmare. But it remains still a fact.
Denying doesn’t help.

Hello, @floripaolo
I’m really sorry for this situation.

The main issue is our Demo Page is working on different mobile devices on Chrome. I tested it earlier, and recorded video for you. Moreover, I’ve just tested it from my phone (iPhone 13, 16.1.1 OS, latest Chrome version) and it is working.
Exactly for this reason I mentioned, that it is possible that issue is related to the device.

Please let me know an exact model of your phone, your OS version and Google Chrome version on your phone.
We will try to find similar device and test it.

I hope on your understanding, that it is not possible to fix something that you can’t reproduce anywhere. But we want help you :pray:

Please let me know parameters of your phone, and we will test it in similar conditions.
Right now, our Developers could not find any root cause of the issue ( in the plugin’s code, console and etc.)

Looking to hearing from you soon.
Best regards,

1 Like

Hello @Ecaterina

Something that might be relevant. occurred:

We have two exact same iPhones in house:
iPhone 11, iOS 16.1.1

One with Chrome 107.05304.101 (mine) where Apple login does not work in Chrome and app. But works on Safari.

The other iPhone with an older Chrome version installed (89.xxxx…) where Apple login was working on Chrome, App and Safari.

As soon as I updated the second iPhone to the last Chrome version, Apple login stopped working from App and Chrome. But still was working on Safari.

I deleted Chrome from my phone, restarted the phone and now Apple login is working.

Therefore Chromes browser is at the base of the problem

Hello, @floripaolo
Thanks for this useful note.

So, if I understand correctly, you installed Chrome once again (after removing it) and Apple signing worked correctly?

It seems like the issue is related to 16.1.1 iOS and the latest Chrome browser Updates.
We made research on official Apple forums and found out that many users facing such an issue with signing in with Apple on the latest iOS version (even me, when I’m trying to sign in with Apple at different Marketplaces, like Amazon).
And this behavior is absolutely random.

Please note that our plugin is based on the official Apple Library, and in case there are some troubles there, we can face them too.
We will continue our research, but unfortunately, I can’t ensure you that solution will be found immediately.
Thanks for your understanding.

Best regards,