Templates Plugins Courses

Audio Recorder error ❌

Hi @levon

I get this error, pointing to an old library? I don’t have the same result as the demo.
Using latest version 1.14

Additional notes with the version I’m using:

  • it stopped to record after 3 recordings (not the case with the demo)
  • if I used the recorder with any player in a group, the recorder record empty sound.

The demo version https://zeroqode-demo-04.bubbleapps.io/audio_recorder is working, but not the version-test. I don’t know if it is related. (update: the demo is working now… Bubble error).

maybe worth uninstalling and reinstalling the plugin?

1 Like

Same result. But it was worth trying, I have to admit. When I refresh the browser, the first thing to show is this error, before anything else. I assumed the actual plugin is not of the same version as the one used in the demo.

are you using the private version or commercial?

We have changed last time for commercial.

we’ll try to check, thanks

1 Like

I’m confused… when I removed the plugin, it indicate the same error! That’s sound also Bubble error. So, I create a brand new page, with only the recorder, it works. Some faulty cache? Unlike the demo, the use of .ogg instead of .wav isn’t giving the same compress audio.

perhaps, not sure about that. But indeed seems like a Bubble problem, can you file a bug report with them please?

Definitly not having the same version as the demo. Will send a bug report for the cache thing to Bubble.

Hi @levon

Bubble ‘cache’ issue is fixed. We need a way to be sure Bubble is using the latest audio recording plugin (ver. 1.14) in Chrome. Can you checked if there’s no mixed compilation between the ZeroQode experimental plugin versus the commercial plugin?

  • After 3 or 4 recording, the plugin shows an error (demo and my app).



Hi John! @johnmark

Reproduced the issue with the demo page recordings, after 4 recording the plugin stops working.
We’ll look into in and provide a fix asap.

As for versioning between Testing and Commercial one shouldn’t be the case, but we’ll double check if there is something wrong.


1 Like

Hi @Dumitru,

There’s also

  • The audio compression format .ogg give the same result as .wav instead of 3x compression.

or maybe add the format mp3 (5x)?


Can you add to ZeroQode demo the ZeroQode plugin player inside a group with the recorder? It doesn’t work for me in iOS (still don’t know if it a Bubble or plugin error).

Hi John!

This will be troublesome, since changing plugins between test stands will break the other page demo and reverting back will not always retain the same flow.
If you could setup a test demo page for the scenario in your app and give access to our devs, plugins@zeroqode.com so could look closely what’s causing the issue would be much appreciated.

If I understood correctly the ogg compression is not actually compressing the file? Thanks.


We pushed an update to Audio Recorder issue recording on Safari:

  • Fixed unable to record more than 4 times bug in safari.

yes isn’t compressing.

1 Like

Hi @Dumitru and @levon ,

Major issue that does not update the latest version of the plugin in Bubble. Update 1.15 didn’t work as expected but ZeroQode demo did. So I remove the plugin, reinstall it, and nothing changes (even old version 1.14). Then I install my private edition of audio recorder plugin from ZeroQode and remove it. Version 1.15 works now! What do you think?

If you want me to send a bug report to Bubble, I will need a way to show in Chrome the current version of the audio recording plugin. It’s major imo for all plugins.

Hi John!

Thanks for info, I believe you could send a bug report by showcasing a video recording of the plugin update process of your app which will not upgrade for some reason which should fix the issue and show the recording our demo setup which is the latest version of commercial plugin with a fixed issue already.


Hi @johnmark

We checked the combination of both plugins Audio Recorder and Player. The issue with this combination, comes from safari. The player can’t play .ogg or .webm in Safari, however it can play .wav format in any browser.

Also we’ve updated the plugin with a fix:

  • Bug fix Plugin wasn’t compressing files. Compressing works in any browser except Safari and Edge.

Thanks for patience and understanding.



Hey @Dumitru, .wav works just fine but the file size are way above the 50mb limit for recordings above 5mins.

Is there away to record into an MP3 format since that will work for both Safari and other browsers like chrome?

Hi, @lweili!

Thanks for reaching out!

Let me check this opportunity and I’ll get back to you asap. Thanks for understanding!

Best, Julia.

1 Like

@julia.minacova That will be much appreciated, or perhaps implementing ffmpeg for other formats that work well with Safari like m4a. Right now I’m forced to alienate iOS users completely.

While we are here as well, one great feature add to allow even more flexibility is to have control of when we want to upload the recording rather than having it automatically upload to AWS upon stopping the recorder (Similar to the native bubble file uploader). This will save a ton of AWS storage for things like redos.

Happy to provide detailed context, examples and links to the parts of my app where I’ve implemented the recorder.

Thanks again for looking into this, will wait to hear back before finding alternatives or hacky ways to get this working for iOS users.