Templates Plugins Courses

Autcomplete List of country doesn't work


#1

When I try to use a list of country, no result are returned at all.


#2

can you please share some screenshots so we see how you configured it?


#3

ss02_zq

Both setting in plugin and in DB. Text field in DB. So using search, this is a list of text fields.


#4

I think you misunderstood the purpose of this plugin. This plugin searches through a Google Places api and returns business locations for cafes, shops, banks etc.
The “countries” field is not for letting the user find a country but only for limiting the countries where Google will be searching for results.
Makes sense?


#5

This is exactly what I’m doing.
If I set one country in the “Country” field. I have no issue and result will be in this country. The countries list should do the same but with a list of countries instead of just one. But it doesn’t work.


#6

@levon
Any news on that?


#7

still checking, sorry for the delay


#8

how many countries do you indicate? Google limits to only 5 countries. Please make sure you are not exceeding that.
Thanks!


#9
  1. Exactly like the screenshot. I also try just 1 and it didn’t work

#10

did you try listing the same countries directly in the input without referring to the database?


#11

also, are you on plugin’s latest version?
and did you implement it like this? see screenshot


#12

We don’t have the map present on the page. So We don’t check this box.
We are on the latest version
And we cannot manually enter the CSV list of country. It doesn’t work.


#13

we’d need access to your app to troubleshoot, please add [email protected] to collaborators so we can check
thanks!


#14

Done. Page tidsted to find the autocomplete


#15

we’ve just fixed it for you. Please double check
thanks!


#16

@levon
Seem to work fine now. Thanks!


#17

Glad to hear!

If you like our plugin, could you please rate it by going to Plugins tab in Bubble editor? You can find the plugin by name and give it as many stars as it deserves :slight_smile: The more feedback we get, the more motivated to build great plugins :slightly_smiling_face:

Thanks!


#18

Hi!
Finally talk to fast. Seem to work in dev mode but not in live mode
But now the list is not empty, but this return results all around the world and this seem to be like if we didn’t set the API key


#19

did you copy your database from dev to live?