Templates Plugins Courses

AWS S3 Uploader Not Pulling Any Files (No files even though there are)

So I am connected to my S3 Bucket and I am able to upload files with no issues. Currently, I am not able to GET files from my S3 Bucket…

I have the S3Objects element on the page and when page loads and on “Get” button I am running the workflow “Get all files from s3”. I know it’s not working as I am using the data “S3Object A’s List of filenames:firstitem” which is empty. I have tried many combinations. I can confirm the bucket is not empty.

image

Hi @maxlouiscreative,

Thanks for using our products! I can recommend you check our demo editor here, to see how everything is set up for getting your S3 objects in a RepeatingGroup. You can simply replicate and give it a try again.

Best,
Alex

Hey! Thanks for the quick reply.

That’s actually what I did. I also uninstalled the plugin and reinstalled and recreated the whole setup to find the same result.

Just to also let you know that the demo, when copy and pasted into my app, gave errors that the elements didn’t exist as I didn’t have the plugin. It looks like you are using a testing version of the plugin for the GUI part of the plugin on your demo page.

Also another note, the documentation to set up AWS S3 for this plugin is a little conflicting with the screenshots provided and the code provided on the page. I suspect this might have something to do with it? This is the docs I am referring to: https://docs.zeroqode.com/plugins/aws-file-uploader-plugin#4-aws-s3-bucket-located-on-the-desired-server

Thanks!

Hi @maxlouiscreative,

Thanks for feedback. Yes you are right, there might be issues in your editor when you try to copy and paste, becasue you might not locate a plugin element on your page so you actually need to add one or replace to make it work.

For our docs, could you please relate a bit what exactly is conflicting? Because if you follow all the steps as per our instructions, everything should be up-and-running on your side. Could you please make sure whether or not it is configured the right way, then give it a try. But if it still doesn’t work, we’ll take a look into your app. :pray:

Hey!

I believe this might be an issue with the CORS or other permissions settings given on the documentation page that is causing nothing to get from the S3 Bucket.

If you look through that I sent on my previous post, you’ll see there is code to set up the AWS permissions/security in both images and on the page as text. I copy and pasted from the text on the page, but the images have different settings. Are we sure your permissions are set up correctly for AWS on your documentation?

Found it!

Public access must be given not only on the “block access” page, but also the “Access Control List”. I ticked “everyone” to have list permission and they are now appearing!

Thanks for your help. I hope this helps someone else in the future.

1 Like

Hi @maxlouiscreative,

Thanks for feedback. I’m glad you managed to fix it. If you like our plugin so far, could you please rate it by going to Plugins tab in Bubble editor? You can find the plugin by name and give it as many stars as it deserves. The more feedback we get, the more motivated to build great plugins!

Thanks!