Templates Plugins Courses

AWS Trouble with audio files


#1

Hey guys,

I’ve tried about 20 times with totally new AWS accounts and buckets and i can’t get this thing to work.
What DOES work is uploading images.
I don’t want images - i’m trying to upload mp3s, wavs and aifs.

I always get the xml error with audio and video files (everything but images).

Please help!


#2

Hey @trackerfied,
Hope you are doing well,

Can you please provide us the setup properties of Plugin elements, because i was trying to reproduce the same issue, but it works perfectly for me, so i think you have some errors in setting up the plugin for your application.

Thank you.
BR.


#3

soundbasebucket2
ap-southeast-2
ap-southeast-2:2a28d3a8-22dd-4c29-8537-[removed for privacy]

{
“Version”: “2012-10-17”,
“Statement”: [
{
“Effect”: “Allow”,
“Action”: [
“cognito-sync:",
"cognito-identity:
”,
“S3:"
],
“Resource”: [
"

]
}
]

same as other policy…

Any other settings you’d like? – Could you please provide a link to your working app (not the plugin demo)…

I followed the ZQ documents perfectly, so unless they’re out of date - there’s nothing wrong with my setup. (meaning you must be doing something different to the docs)

Perhaps you could do a video walkthrough of setup – that way we can be sure it’s all perfectly right.


#4

@Nikita.S any more info?


#5

I have the plugin set to .mp3, but i’ve also tried with nothing and also tried with .mp3, .wav, .aif.
Ran it with dev console open and this was the result:


#6

@Nikita.S @levon
Any ideas? I’m in the dark here…


#7

Hey @trackerfied, thank you for the detailed info, our team works on this now, and i will update you of the matter asap.

BR.


#8

@trackerfied also, check this one input field in your AWS Uploader element, if it is not set the same, change it and try again to upload an MP3.

If it is the same, please make screenshots of all your properties of AWS Uploader Element.

Thank you.


#9

@Nikita.S

As I mentioned, I have that set to .mp3
I’ve also tried leaving it to ‘all’
I’ve also tried using .mp3, .wav, .aif


#10

Hi @Nikita.S, i just tried ‘all’ and nothing happened.

Here’s the result:

Uncaught (in promise) TypeError: Cannot read property ‘get’ of null
at eval (eval at m.create_code (x5:15), :12:367)
at new Promise ()
at H (eval at m.create_code (x5:15), :12:320)
at eval (eval at m.create_code (x5:15), :16:483)
at new Promise ()
at I (eval at m.create_code (x5:15), :16:459)
at eval (eval at m.create_code (x5:15), :21:429)


#11

@Nikita.S @levon Some help woud be greatly appreciated! :slight_smile:


#12

Hello, @trackerfied we found a bug and our team is working on it. I will update you of matter asap when we will fix it.

Thank you,
BR.
Nik.


#13

Hey @trackerfied, the issue is fixed you can try it now,
thank you for you patience and cooperation,

If you like our plugin you can rate it by going to Plugins tab in Bubble editor. Find the plugin by name and it give it as many stars as it deserves :slight_smile: The more feedback we get, the more motivated we are to make things better in Bubble.

Thank you,
BR,
Nik.