Templates Plugins Courses

AWS Uploader - first file is not uploading - more than one are working fine


#1

hi zerocode team,
thanks for your nice plugins.
My new AWS-file-uploader is doing crasy things. trying to upload files. giving back error 403
when i try to upload more than 1 file it is uploading the other files nice. the first one has still that error.
any idea?


#2

I dont get the error. The other files are uploading fine.


#3

Hello @mrkabelbruch

There a few things you should troubleshoot in your amazon dashboard : (https://aws.amazon.com/premiumsupport/knowledge-center/s3-403-forbidden-error/)

  • Missing permissions to use an AWS Key Management Service (AWS KMS) key
  • Bucket policy requires encryption
  • Bucket access control list (ACL) doesn’t allow the AWS account root user to write objects
  • CORS Settings

#4

I am checking here everything. It is super frustrating. Cant find the problem.
Why can i write some files?


#5

I’m noticing the same error. Were you able to figure out a solution?


#6

No, sorry. I cant help you with this. I am still stock here. I dobble checked everything. I did everything in the manual…


#7

Hello @mrkabelbruch @amcrossl23

I would recommend you double check everything in your setup, from misspelling to the aws region selected, identity pool id and bucket name.

Also the see that your ~/.aws/credentials file and compare the aws_access_key_id with the key id generated for your account.
If everything appears to be correct, please try regenerate a new set of keys and use them.
Also try uninstalling, and reinstalling the plugin. Placing new element after that on page.
Clear cache/cookies.

Best,
Dumitru.


#8

Hi @Dumitru. I have triple checked everything in the documentation and our setup. Everything works great for images. The problem is only with video and works maybe 10% of the time which is odd.

Could you expand on this part as I don’t see anything in the documentation about aws_access_key_id.

“Also the see that your ~/.aws/credentials file and compare the aws_access_key_id with the key id generated for your account.”

Thanks,
Adam


#9

@Dumitru How can I report a bug?

I’ve done some extensive testing and have a repeatable error I am getting. Please see below:

  1. I upload a video and it throws me this error error
    01%20AM

  2. I can continue to try and load the video and the same error will be given.

  3. If I then attempt and load a picture, it will work. I can then go ahead and post this uploaded picture to the social feed in my app.

  4. After I load the picture I am then able to load in both videos and pictures no problem. However, I am only able to load the videos after I have already loaded a picture.

This definitely sounds like a plugin issue and not a bubble or a setup problem on my end as I have followed the documentation and attempted reinstalling/installing multiple times.

Can you please advise on how to log a bug report?


#10

Hello!

We’ll check this out and provide an update on the matter asap. Thanks for understanding.


#11

Hi @Dumitru. Do you have any update?


#12

Hi @amcrossl23

Sorry for taking this long, however seems like the issue will take some time to solve it. The AWS ticket however is one of top priorities, to provide a solution for.
Looks like more users in other threads are reporting somewhat similar situations with audio and video files failing to upload.

Thanks for understanding.


#13

@amcrossl23 @mrkabelbruch Hello!

We pushed an update for plugin, please update to it and give it a try.
Place the element on page and refresh the app.

Regards,
Dumitru.