Templates Plugins Courses

AWS Uploader not returning "List of Filenames"

Hi,

The S3 Objects element included in the plugin is not working as expected. All values (e.g., list of file urls, last modified, etc.) are being returned by the “Get all files from s3 action” except for the “list of filenames”. I confirmed this via my app, and I also confirmed that this is not working on your demo page either.

Can you please look into this and help me understand what the issue is?

Hi @nowicki.greg, thanks for reporting this issue.
I’ve passed it to the developer team for investigation.

Once any results will become available, I will let you know asap.

Thank you for understanding :pray:
Regards,

Thanks. I also found one other issue - the filename prefix does not update dynamically.

In my app I have a filename prefix that’s dynamically driven using a custom state on a page element. When the state is changed, the filename prefix should update, but I notice that it does not. Below is a screenshot of my setup:

Both of the issues noted are found on plugin version 1.82.0.

Hi @nowicki.greg, thanks for your message and provided description.
The developer team will check this moment too, and once any update will become available, I will let you know :slightly_smiling_face:

Regards,

Hi again,

One more issue with this plugin (total is now up to 3) . This time the “Delete Files” action does not seem to pick up the list of file URLs that need to be deleted from s3.

I am storing the list of URLs to be deleted in a custom state and the list is being passed tot he “Delete Files” action. I am certain that the list is correctly stored in the custom state (despite the debugger showing no values) as I am printing in the the UI (via text box) and I have another action in the same workflow to delete those records from bubble DB (I am storing additional meta data needed for the file record), which is working as expected using the same list. Additionally, if I inspect the element where I am storing the list of file url’s in a custom state I can see them stored correctly.

Here’s the setup of the “Delete Files” action.

At this point i’m a bit frustrated with this plugin as most of the elements of the plugin are not working except for the upload to s3 functionality. What is going on? Please help me understand ASAP as I am unable to move forward with development on this app. If this takes any longer I will need to move onto developing my own API workflows.

Hi @nowicki.greg, thanks for the provided details.

Following the provided description, it might be possible that at some workflow step, passed values are empty.
In the case of the filename prefix, to be sure that it is passed properly, please display them on a text element also, it will allow you to check if unique ids are indicated right.
We’ve checked on our side how the plugin works, and the filename prefixes from unique ids have been inserted properly.

In regard to the “Delete files” action, as you’ve mentioned, the debugger shows no passed values, so plugin action can’t act with no values. Please check the correctness of your setup on the step when the value becomes empty.

In case if after recheck the issue will persist, please let me know and share (here or in DM) a screencast with full workflow setup and use case flow with the opened debugger.

Looking forward to your reply.
Regards,

Hi @nowicki.greg,
We have pushed a plugin update, that has fixed the issue related to no file names displayed.

To check changes, please upgrade your plugin to the latest version (Version 1.83.0: improvement with function to correct the image orientation) and give it a try.

Have a nice weekend ahead!
Regards,

Hello,

I have taken a look at the update and can confirm that the list of filenames are being returned. Thank you! However, I’m still facing an annoying issue with the filename prefix feature and I desperately need it to work.

I’ve tried several workarounds to get the file prefix to work, but have not had any success. As a reminder, in my app, the file prefix can be updated based on a custom state of a page element. Here are my observations. Please take a look and let me know if this is user error or in fact a plugin error:

In my app, I have set the Filenames prefix to “side navbar A’s Workspace’s unique ID”. Side navbar A’s Workspace is set using the dropdown menu as shown in the screenshot below. I have also added a text box to show the current workspace’s unique id which should be the filename prefix.

When the page is loaded, the dropdown value default’s to the user’s first workspace (in this case workspace 1). This also triggers the side navbar A’s workspace custom state to be set to workspace 1. Please note the unique ID of workspace 1 → 1618686826048x827443259031930100.

Now, before uploading any files using the uploader, I change the workspace value using the dropdown to Workspace 2. This sets the side navbar A’s workspace value to Workspace 2 and the appropriate unique ID is displayed in the text box —> 1618686842646x763813870807133600.

Now, I upload a file using fileuploader A element. I expect that the file name will be prefixed with the current workspace unique ID (1618686842646x763813870807133600). However, when I view the file in my S3 bucket, the filename prefix is incorrect as it is still using the previous workspace unique ID (1618686826048x827443259031930100)

In summary, it appears that the filename prefix value is not dynamically updating in the plugin even though it is clearly working in Bubble as proven by the text box always showing the correct value. Please take a look into this.

Hi @nowicki.greg, thanks for your reply and provided details.
For a better understanding of the possible cause, would it be convenient for you to add our [email protected] as a collaborator of your app?
That will allow us to check what’s wrong with your setup and test it out in our workspace.

Enter your Bubble editor page → Settings → “Collaboration” tab → Invite a user (email).

(Note: disregard the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.)

I will check your setup and do a few tests in an attempt to find the root cause and help you fix it.
In case it is ok for you, please let me know.

Regards,

Hi @Serg - I have added [email protected] as a collaborator. The plugin is currently being used on the “project_file_manager” page. Please let me know if you need anything else.

Thanks,
Greg

1 Like

@nowicki.greg, thanks for the provided access.
We’ve checked the upload file flow and by the end of it, it returns the right id (we’ve changed the dropdown option a few times).

Please share in DM a screenshot from the AWS dashboard with the name of the uploaded file.

Looking forward to your reply.
Regards,

Hi Serg, I can confirm that the file in AWS is NOT saved with the correct prefix. I understand that you’re seeing the correct value being passed to the plugin, however, when the file is stored in AWS the prefix is incorrect. Therefore, there might be an issue between the plugin and AWS integration - do you think that’s possible?

Please try the following tests (defined below). To help, I have replaced the file name in the RG with the file URL from S3 (using get s3 objects action after file uploader finishes upload). You will notice that the file name prefix (in the URL) is not the same as the workspace uuid value.

Test #1:

  1. Load project_file_manager
  2. Select Workspace 2 from dropdown
  3. Upload file

Test #2:

  1. Load project_file_manager
  2. Select Workspace 3 from dropdown
  3. Upload file

Test #3:

  1. Load project_file_manager
  2. Select Workspace 1 from dropdown
  3. Upload file

If you would like, I can show you the screenshot in S3 confirming the same issue.

Hi @nowicki.greg, thank you very much for such a detailed use case.
Indeed there is an issue with the uploaded file prefix. I’ve passed this case to the developer team for investigation.

Once any news will become available, I will let you know.
Thank you for understanding :pray:.

Regards,

Thanks for confirming. I will be on the lookout for a response.

1 Like

Hi @nowicki.greg, thanks for your patience.
We have pushed a plugin update, that should fix the earlier reported issue with file prefix error.
To check changes, please upgrade your plugin to the latest version (Version 1.86.0: Fixed problem with the dynamic prefix) and give it a try.

In case the issue will persist or there will be anything else about our plugin that I can help with, please let me know.

Have a nice weekend ahead!
Regards,

Hi @Serg - I just did a quick test and it appears to work as expected. Thank you to you and the team for resolving both - much appreciated. Will reach out in case I spot any additional issues. Have a good weekend!

2 Likes

Hi @nowicki.greg, thank you for letting me know that the plugin update solved the reported issue. :hugs:

Have a good week!
Regards,