Templates Plugins Courses

Background video plugin

Hi there,

I have just purchased this plugin and my video plays on desktop but not Safari.

I can see from the updates that this was fixed though?

If you could help it would be greatly appreciated!

Thanks

Hi @realprojectfalcon,

Thanks for reaching out. Unfortunately, this issue is not reproducing on our side. The plugin is working properly on both iOS and MacOS Safari. Could you please indicate which browser and OS versions you are using?

Also, please make sure to configure the plugin as per our doc instructions here, then give it a try again.

However, if you still experience the same or any other issues, please share more details like screenshots and/or a screenast of your app setups, plugin configurations and workflow actions, so we can replicate the same steps in our end.

Best,
Alex

Hi Alex,

Please see setup below. There are no workflows as it is set to autoplay.

Sorry to add I am using the latest version of Safari

Hi @realprojectfalcon,

Thanks for feedback. Unfortunately, the autoplay will not work in Safari. Please refer to our docs here.

This is due to browsers policy, they do not like the autoplay, unfortunately.

Best,
Alex

Hi Alex,

Ah well thats quite misleading as it states when the mute feature is not enabled, then autoplay does not work.

I would therefore presume if the mute feature is enabled then it should surely work?

Hi @realprojectfalcon,

Sorry for misleading, we’ll make an update so it doesn’t confuse. Yes, this is correct - muted autoplay is allowed and is going to work, but this is based on Chrome policy. The Safari will not work for sure, unfortunately. :pray:

Best,
Alex

Apple says differently. Why is Safari still not working on iOS? https://developer.apple.com/documentation/webkit/delivering_video_content_for_safari

Hi @janheinemeyer,

Thanks for reaching out. Please let us investigate this request then get back to you with working solutions asap!

Best,
Alex

I have implemented my own HTML now and it works. The problem with safari seems to be in the details. I am using:

<video style="position: relative; left: -115%;" class="video-js" playsinline autoplay loop muted>
    <source src="my_URL" type="video/mp4"/>
</video>

Hi @janheinemeyer,

Thanks a lot for the feedback. I’m glad you managed to solve it on your side. Still, we are working on the plugin fix because you are actually right, it is possible to use the Autoplay in Safari under the same browser policy as Google allows to use, and the weird thing is that our plugin is actually built to allow it, but it doesn’t work, unfortunately.

Our development team will try to fix it asap so you can use the updated version, without implementing any custom code if you will. :pray:

Best,
Alex