Templates Plugins Courses

Browser Push Notification Doesn't work


#1

I installed the push notification plugin days ago, the installation is so simple and the use (i saw the demo) as well, so i don’t understand why the pages i put notifications on don’t ask me to authorize the site in order to show them.
Is there anything i must do a part from installing the plugin and start using it in the workflows ?


#2

Hello!
The plugin setup is very straightforward indeed, and consists from installing the plugin and adding the workflows only.
Could you tell me in which browser are you testing your application? Also, could you check that you didn’t grant or deny the permission already? This information is in browser settings -> notifications.
For example, if you use Chrome, go to Settings -> Advanced -> Site Settings -> Notifications and check the URL of your application.
Kind regards,
Olga


#3

hI
I’m using Google Chrome, and i just checked in the settings the list of the site blocked, my app address isn’t there, normally it should ask me to allow or block the first time the worklfow is running.
I could add my app address to see what’s happening but i’m scared that another user on a different browser won’t be asked in the case where this works
Thanks for caring


#4

Could you please test it in some other browser, while we’re looking for the root of the problem.
Also, do you have any AdBlock, ScriptBlock extensions installed? Could you try it in Chrome Incognito Window as well?

Regards,
Olga


#5

I tried on Firefox(Not OK) Chrome Incognito (Not OK) Microsoft Edge (It worked !!!) Opera (Not OK)
Regards


#6

One more question: do you have a custom domain of your app?
If yes, could you go to Settings - > Domain/Email and check that HTTPS is set up correctly.
The reason I’m asking is the Notification API may not be used from insecure origins in many browsers.
Regards,
Olga


#7

Ok, That might be the reason, I suppose microsoft edge doesnt use this security, i will try to set this ssl pb for my domain, and get back to you


#8

But it happens even in the development part of the app which is under bubble right ?


#9

Yes, it should work under Bubble. Could you give me a link to your test page please? I’d like to see if it works in my environment and to check the console errors. Thank you!
Olga


#11

Sorry I made my app every one can edit so:


#12

Thank you!
I’ve checked it. As you use custom domain, it should be secured in order to see the Push Notification request.
That’s not an error in plugin, it will be fixed once you have the HTTPS connection.

So the fact that it works in Microsoft Edge is the flow it the browser security that is not fixed yet as MS Edge is relatively new browser.

Install the SSL certificate for your domain and check again please.

Kind regards,
Olga


#13

Ok i will do that
Many Thanks