Templates Plugins Courses

Bubble Page to PDF Converter plugin - not working AGAIN

Hi all,

Following the last query from today, I am using the ‘page to pdf converter’ plugin, every couple of days it stops working. I upgraded to ver 1.6.6. today - but still nothing helped.
Can someone help me please?
The business is losing customers due to inability to produce quotes and invoices.

Thanks,
Bittas Team

Hello @Bittas_Magic,
Thank you for reaching out!

I’ve also replied in another forum thread. Could you please check the provided suggestion here:

If it doesn’t help, can you please provide more details on the issue that you are having? Specifically, screenshots or the video recording of settings, and your whole setup. :pray:t2:

Regards,
Gulce

Hi thank you for your response! I have sent you a private message with a video (due to sensitivity issues not on the public post). The video shows what happens with my app, as i am waiting a few seconds and then producing it, and how it turns out.

1 Like

Also these are the workflow views:



Same as it was for months.

Thank you for your help!

Hi @Bittas_Magic,
Thank you so much for the details. :pray:t2:

First of all, can you please make sure that you are using the latest plugin version? Also, please let me know if you’ve tried my suggestion in the previous thread, here: PDF converter bug - SOLVED - #5 by gulce.besel

Here is a video for a better understanding: Loom | Free Screen & Video Recording Software | Loom

As I can see from the screenshot, the ID field is empty in the plugin action, but I assume you specified the invoice ID when recording a video as it can be converted to PDF.


Please make sure to indicate the ID value in the ID field if you are choosing the “Single element” target. Otherwise, the plugin will not convert this element, because you have not specified which element to convert.

In case you had an ID value there and removed it for the screenshot - please let us investigate the plugin work withing your app. For this add us to the list of your collaborators (Settings → Collaborators → add support@zeroqode.com).

Hope to hear from you soon.

Best,
Gulce

Hi,

Thank you very much for your response.
I must say, this is very strange! You are indeed correct, there was no element-ID (in live version).
The thing is - I didn’t touch it, and in the development version there is an attribute-ID, but now as you have mentioned the live version doesn’t have that element-ID, can you explain what happened? maybe it was due to the version updates in bubble and in the PDF plugin?
I’m just trying to figure out in order to prevent following accidents with our clients.

Many thanks,
Bittas Team

Hi @Bittas_Magic,
I’m glad the issue is solved!

I’m afraid, it would be misleading to say the exact problem, as neither we nor the users have encountered such an issue. Apologies for not being able to help in this regard. In case you will have any other issues or questions in the future, you can always contact us, we are always ready to help. :slightly_smiling_face:

Also, if you like our plugin, you can rate it by going to the Plugins tab in the Bubble editor by sharing your experience with the rest of the Bubble community. You can find the plugin by name and give it as many stars as it deserves. We would appreciate it a lot. :pray:t2:

Regards,
Gulce

Hi Gulce,

Thank you very much for your answers and help.
I have just deployed it to ‘live’ version, and i got this message:

The plugin Bubble Page to PDF converter / action Generate pdf from html server side a Converter to PDF v2.0 threw the following error: TypeError: Cannot read properties of null (reading 'style')
    at eval (PLUGIN_1526888373861x305666508856229900/Bubble-Page-to-PDF-converter-element_action--Converter-to-PDF-v2-0-Generate-pdf-from-html-server-side-.js:53:23)
    at https://bittas-app.co.il/package/run_debug_js/dbd4db82402c3c5281d023fd7d633e8d1d578d0195091beddc1120e66eaa72dc/xfalse/x17/run_debug.js:6:2479933 (please report this to the plugin author)

Can you help me figure out what has gone wrong with the plugin call?

Thanks,
Noam

Always welcome. :slightly_smiling_face: @Bittas_Magic,

Can you please send me once again a full screenshot of the error message? Also, please provide more details on when exactly you are getting this error. Any screenshots/screencast and additional explanations will be highly appreciated.

Looking forward to your reply.

Best,
Gulce

Hi,

Ok, I looked deeper and found that there was a mix in the merge with some internal legacy code on our bubble app - fixed the mismatch and all is working well - thank you!

Best,
Bittas team

1 Like

Hi,

Again, it is not working.
When I convert the PDF for the first time it looks ok, but when i keep browsing the app and return to it it scrambles the page all over again.
Also, I tried converting a whole page - then the PDF was output correctly.
Tried reverting it back to the Element needed - and again it was scrambled.

Am I doing something wrong?
It used to work a few months back… I really don’t understand what happened and what I can change to make it work again.

Many thanks,
Bittas team


Hey @gulce.besel
Another a weird thing that I ran into while trying to re-copy your workflow is that your new method in the workflow doesn’t have an ID either now.
Can you explain it please?
Thanks!

Hello @Bittas_Magic,

I’m afraid the provided screenshot is not enough to identify the possible issue. I’ve tested the plugin once again and it’s working normally. I would like to help you out. For this, we need access to your app to find out the root cause of your issue and find a way to fix it. :pray:t2:

Therefore, can you please add our Support email to the list of collaborators to your application and provide me with a link to your application, so I can take a look at all the issues you have?

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com. You can do this even if your app is on the Hobby plan, as our account is on an Agency.

Thanks!

Gulce

Hi @gulce.besel ,

Thank you so much for the cooperation and willingness to help!
It is really important for our organization.
I’ve granted you permissions and sent you the link to the app along with a detailed tutorial on how to produce the PDF in the app.

We can continue communication directly and share the final results here in the forum.

Many thanks!
Bittas Team

P.S. After a few more digging deeper into the process I found out that also the full page didn’t work correctly. The actual problems occur after the first PDF creation.
When I update my app and produce a PDF it works fine, and the it reroutes me back to another page of the client, then if i am trying to produce another PDF it turns our scrambled - consistently after changing many parameters always when I go to another page and come back the PDFs created turn out scrambled. So just wanted to share this insight here as well.

@Bittas_Magic, thank you so much for the details. :pray:t2:

Let us check what might be the issue, as soon as the investigation is completed, I’ll get back to you.

Best,
Gulce