Templates Plugins Courses

[BUG] Anything to Image - Custom CSS not visible

Hi everyone,

I ran into a problem with your plugin “Anything to Image” when I was trying to convert a group of elements into an image.

The group I’m reffering to shows a shirt with several elements:

When my customer clicks on “Finish”, I make an image of the shirt he/she designed to use it at the checkout:
Screen Shot 2020-10-13 at 13.05.27

So far everything has been working absolutely great with the plugin for the white shirts.

When my customer decides to go with the black shirt, I assign each element on the shirt a custom css style that is defined in the page header Pulling in the raw white PNGs is currently not an option; hence I have to use the custom css styling on the black ones:

Thanks to the plugin classify, I add or remove the style class to the elements depending on whether the user wants a white or a black shirt:
Screen Shot 2020-10-13 at 12.58.22

So far everything working fine; when the user goes for the black shirt, it looks like that:

NOW: when the user proceeds to the checkout with the black shirt, the image creation process runs into a bug — at the checkout the user sees his/her shirt with the black icons instead of the white ones:
Screen Shot 2020-10-13 at 13.13.20

Any thoughts / help on how to fix that?

This is quite the essential feature for my app, so I’d be extremly happy if that could be fixed.

Thanks very much in advance!

Hi @kjb,

Thanks for reaching out and using our products. I’m afraid it is not a plugin bug because you are using custom CSS and the problem is that the library our plugin is based on cannot use such implementation. However, in order for us to have a better investigation, please go to Settings - Collaboration tab within your editor. Add our [email protected] account to your collaborator’s list. Also, please tell us your app name and page name where this problem occurs on test.

Note: avoid the warning message regarding plan, as we are an agency and you can easily add us to your collaborators.

Also, could you please share the following details:

  • browser and OS version you are using to develop your app
  • screencast of your app and preview, so we can have the exact steps of how to reproduce this issue (user to run your app with, and all the steps to follow)

We’ll investigate it inside your app and get back to you with a feedback asap. :pray:

Best,
Alex