Templates Plugins Courses

BUG - Image Slider

Cannot user the Image Slider plugin. It doesn’t show static or dynamic images.

Here is the console error.
image

Hello @enzotar3000

We’ve checked on our side, and the plugin seem to work as expected. Now errors are thrown.

Can you please provide more details, like workflow setup, some screens/video, also steps to reproduce the issue?
Thanks for understanding.

:pray:

I use an expression, resulting in a list of texts, which works with Bubble’s own slider. Images comes from Bubble’s AWS S3. There are no specific workflows. Inspecting on Bubble shows the list of urls correctly loaded.
Also, I use a legacy Bubble application before they had CloudFare installed, so it is enabled manually, if that makes any differences.

Could it be a conflicts with other plugins?

@enzotar3000

As you can see on our demo page we couldn’t replicate the issue, unfortunately.
I would recommend, for you to create a simple test page which will replicate our demo: https://zeroqode-demo-08.bubbleapps.io/image_slider
Also try uninstalling and installing again, be sure to use the latest version of plugin.
To see if the plugin is causing any issues, or throws errors.
Thanks :pray:

Hello @enzotar3000

We’ve pushed an update to plugin, please upgrade to latest version and give it a try.
Place a new element on page, create a simple test page with couple of images, refresh the application and see how it’ll behave.
Thanks.
:pray:

Hey! I just purchased the plugin and sadly I get the same error. It works fine on a blank page. It works fine in a blank reusable element. It throws the aforementioned error in the group I want it to be in. Weirdest thing: I deleted all other elements and it still doesn’t work.

Hello @thomas

From what it looks, in the screenshot it seems that the Slider Element is not being places inside a Group. It’s actually placed directly on the page inside the UI Builder.
You’re saying that simply on the page it works, but it does not in the Group.

We’ve tested on our side and the plugin works correctly inside the group container:

You could see it on our demo page setup: https://bubble.io/page?type=page&name=image_slider&id=zeroqode-demo-08&tab=tabs-1

Could recommend you to uninstall and install the plugin again, clear cache/cookies for the application, create a simple page logic : place the slider element inside a group container, provide image sources, refresh the app and give it a try.
Hope this helps.
:pray:

Regards,
Dumitru