Templates Plugins Courses

Calendar Time Slots plugin Bug

I have found a bug in your Calendar Time Slots plugin.
When you use Pattern Executor element and choose standard date range Bubble IO data type as Events Type:
image
Then it does not work at all. If you open console you will see an error:
image

That’s because of the wrong code:

Bubble IO date range data type is a JavaScript array with 2 items inside, it’s not a custom object and you can’t select property by name. Please add following code there:

if (Array.isArray(event)) {
eventStart = event[0];
eventEnd = event[1];
} else {…}

Give me a tip on how can I fix this in my project. This bug brings a lot of pain in my project.

Thanks in advance

PS You also have a bug on this page Calendar Time Slots | Plugin for Bubble by Zeroqode Link to Documentation is throwing 404

CC @Anastasija

Hello @alex369.xsa

Thanks for reaching out.

I appreciate the detailed explanation of the issue :slight_smile: While I understand the issue you are having, would you mind sharing your use case with us so that we can understand what are you trying to achieve, and we can potentially offer a workaround for now? (while we investigate the possibility of this fix).

Looking forward to your reply.

@Kirill I need to generate a sequence of date ranges (Slots) to propose customer possible times for reservations and exclude already reserved time slots. I have an entity Listing and it has BlockedDateRanges (list of date ranges). I need to exclude this list of date ranges from the result.
I know a workaround in my case, but it requires the creation of 2 new fields in DB and I need to support them in a lot of places in my app. I want to avoid this

1 Like

Thanks for clarifying @alex369.xsa, I’ll check your request with the team, and I’ll get back to you :slight_smile:

Regards,

Kirill

Sorry to keep you waiting! @alex369.xsa

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hearing from you soon.

Regards,

Kirill

@Kirill sorry, I can’t provide link to application due to NDA.

I have already solved this problem by creating my own plugin.

I understand, glad to hear that you found a solution :pray:

In case any other plugin related issues arise, just let me know :slight_smile:

Regards,

Kirill