Templates Plugins Courses

Cannot get GoogleAutoComplete to work

Please help… I have followed very carefully the steps in the online documentation but cannot get the plugin to work:

I have the Google API Key entered:

I have added the Google Autocomplete plugin to my pop up, as well as the input, Bubble map and text fields:

My input field has an ID attribute entered:

And the ID is captured within the plugin element:

I have a custom sate for the location:
46%20AM

and a workflow that updates the custom state:
32%20AM

Hello @SerPounce

Have you tried replicating our demo setup as a start: https://bubble.is/page?type=page&name=google_places&id=zeroqode-demo-13&tab=tabs-1
https://zeroqode-demo-13.bubbleapps.io/google_places
Also if you’re using your own custom domain, please set the google map keys in app settings, under general tab as shown in the documentation.
https://docs.zeroqode.com/plugins/fastest-google-places-autocomplete#docs-internal-guid-be431ca5-7fff-a34f-3e83-ae6d94b2fa2a

Try this all out, this should be a good start with the plugin.

Regards,
Dumitru.

I am not using a custom domain, and I have followed exactly to replicate the set up from the demo page. This is described in detail in my OP.

Hi @SerPounce

If you’ve followed everything written in documentation and following our demo setup should’ve worked.
Alternatively it may seem to not work on Google Cloud Dashboard side if you followed the instructions. Have you enabled Places API, Google Maps API, also did you get the right keys and using them accordingly, have you authorized the application in google dashboard?
Also please try adding your keys in the General Tab, in app settings.


Please do check it out.
Thanks.

Thank you for the help. I was able to get the autocomplete working.

Can you please advise how I can now display just certain data from the full address, such as city and country.