Templates Plugins Courses

Can't Connect Quickbooks to my App using Plugin

I have purchased the quickbooks accounting plugin. I created the app on the Quickbooks side, plugged the Client ID and Client Secret into my Bubble App, I set up the Redirect URIs, I have a button to login using Social Network. I think i have it all connected properly. But when i hit the button to login, it seems to connect then redirect to my app, but i get an error and it never pulls data in. any idea? here is a screenshot of the error i’m seeing:

image

One thing i’m not sure i have right is the redirect URI. I added a bunch of them with the debugger, without debugger, version-test, production, etc, just to cover my bases. I am comparing my app with the Quickbooks demo editor to see that it’s all the same, but one thing i can’t see is how the redirect URIs are set up. if you can provide a screenshot of how you have the redirect set up from your quickbooks side, that might help me as well.

Hi, @robertpbrinton!

Thanks for reaching out!

So, the error message is declaring that some settings were not set up properly. As long as you have compared the Live Demo with your settings and all are the same, indeed, need to check the URL. The Redirect URL is indicated in the application in a Quickbooks dashboard. The URL is the URL of the page where the plugin is set up. Just in case, please check once again if you set properly the Keys for Live Version and Dev Version as well.

Hope this helps!
Best, Julia.

Thanks, @Julia. I’m still getting the error after checking some things. Here is a video showing all the details of what i have set up. Maybe this will help to see it all more clearly to identify where the issue might be. http://somup.com/cYQoFGXk2s

Hi, @robertpbrinton!

Appreciate for the screen record. So, you don’t need to write all the possible URL, you need to specify only URL where the plugin is set up and where authorization will take place. Please remove all the extra links and give it another try.

Hope this helps!
Best, Julia.

@Julia That doesn’t seem to work either. I tried a bunch of different combinations with single URI and multiple. when i’m playing around with the URIs i will get errors when authenticating related to redirect URI. but i can get around those errors. but when i get around those errors, i get the error from my first message above.

I went to try the demo site again and now that site isnt’ working. here’s a video of demo site not working: http://somup.com/cYQDFVXCHF

Is there a way i can get on a call with someone from Zeroqode to help with this? if not, is there a way to get my money back for the paid plugin that’s not working?

Hi, @robertpbrinton!

I am sorry to hear about your negative experience and I’m trying to do my best to help you resolve this issue.

Regarding the Live Demo, we have checked and fixed the issue, thanks for your feedback! :pray:

I’m afraid, we can help you via forum and e-mail. To help you better and find out what it wrong, could you please do the following:

  1. Add the URL link (version-test and live version) where the plugin is set in the Development section as well as in the Production section.

Summarizing all above, you will have two links in the Production section and two links in the Development section.

  1. Uncheck the checkbox “Use the generic redirect URL” in the plugin settings here

After that, give it another try. If that does not help, please add our [email protected] account to your collaborator’s list in Settings -> Collaboration so we could check the issue inside your application. Plus, please tell us the name of your Bubble application and page name where you develop it, it would be way easier for us to help you solve the issues.

Note: Don’t pay attention to the alert message regarding Professional Plan, as we are an agency and you can easily add as to your collaborator’s list.

Looking forward to hearing from you!

Best, Julia.