Templates Plugins Courses

Datatables thread continued from bubbles forum


#1

I am continuing the thread from here https://forum.bubble.is/t/new-plugin-datatables-updated-09-23-2018-new-design/35321/105?u=bubbleboy

This is a perpetual licence not subscription. I have confirmed with bubble directly that I can uninstall and reinstall the plug-in without being recharged for another perpetual licence.

The issue is in regards to the refresh function. This occurred and you subsequently updated to version 2.3.0 which is the latest version shown within the plug-in. This has not solved the refresh issue.

I have subsequently uninstalled and reinstalled the plug-in. Cleared my cache and every other conceivable combination including from another computer make sure I’m working on a clean plug-in. The issue still persists.

Having uninstalled and reinstalled the plug-in if I copy over the element from your demo application where the refresh is working it clearly states that the plug-in is not installed. This leads me to believe that the version you have working your demonstration is not the latest version which is pushed as an update on the plug-in. I’m not questioning the validity of your development updates but the refresh issue was apparent on version 2.3.0. He subsequently updated the plug-in and also updated your demonstration to show it working. The latest version after this update was still 2.3.0?

I’m more than happy to do a loom… And walk through all the steps in logical order to demonstrate the issue.

It should be noted if I downgrade the plug-in the previous version and try and refresh it does throw the error… Running a refresh function on the latest version yields no results nor error. The debugger shows the actions that there is no results.


#2

Hi there,
thanks for posting this,
yes, a loom video would be very helpful
thanks!


#3

@levon


#4

thanks, we’ll take a look, but it might take some time due to high workload


#5

Hi there,
our dev checked it,
the error message says “Refresh action should have filled next fields: Label, Parent”
it looks like you filled out the label field but not the parent one.
that should fix it
Also, you can use plugins " A table error happened event " and show the content of error there instead of Bubble’s error popup.
hope this helps
thanks


#6

@levon I think we are at cross purposes… Label and Parent are the database things in your demonstration and have no relevance to my application.

If you could please check the video again in you will clearly see that the load table use is the thing ID and list which are in my database and the refresh option uses the same. The error provides no indication because it seems if you watch the debugger nothing is actually happening. Unless I downgrade to a previous version when I get an error and then the refresh works

This is all in the video

As mentioned when I copy across the element from your demonstration it clearly shows (see the console error) the plug-in is not installed!


#7

In our example it’s label and parent in your example it’s id and list
because you are using these 2 fields when you initialize the plugin you need to use both when you refresh data as well.

to capture the error, as I mentioned before, use the event "A table error happened event " we have enabled it in the latest update so that Bubble doesn’t through an error popup to the user, but you can return the error state from the plugin and use it for debugging safely.

this might be standard Bubble behavior not sure.


#8

@levon thanks thats solved the issue. Just a humble suggestion it might be useful to update your documentation to highlight refresh must explicitly be the same as page load.

One further question… Your documentation explicitly states that when selecting a row…the ID is returned which in turn can then be used to search or filter. In every test I’ve run its not the ID but the first item in the table which is returned.

I’ve checked your demonstration which I believe did previously have a pop-up presenting the selected row thing but it’s no longer evident in the demo. Could you confirm back that it’s actually the ID which is meant to be returned?


#9

but it’s already there


https://docs.zeroqode.com/plugins/datatables-plugin

we’ll check this out and get back to you


#10

How can you show a list of values in a column? I want to show a list of texts in one of the columns. What should my search look like?


#11

Hello @Bubbleboy.

The uniqueID constraint is used when the row is clicked event, Table Row event gets the unique id of that row. So doing a search for X: first item (in properties of the search we will use unique id= this row). As noted in documentation uniqueid MUST be the first row ONLY IF you want to use on-click event.

I updated the demo page with such event, you could check it here - https://zeroqode-demo-16.bubbleapps.io/datatables

@calebs see the demo page how it is set and try replicate it, also you could adjust it under your use cases.

Regards,
Zeroqode Team.