Templates Plugins Courses

Easy File Downloader Issue


#1

We have encountered an issue with the Easy File Downloader that appears to have occurred just recently. The scenario which causes the issue is as follow. The user uploads files and we attach them to a record that the user has permission to “View Attached Files” in the Privacy rules. The issue is that the Downloader control does nothing when we run the “Download File” action on any of the newly uploaded files which did work in the past. To test whether or not security was an issue we put a Link control on the form that pointed to the newly uploaded file’s URL and it worked normally when the user clicked it indicating that security was correctly applied. But what’s even more strange is that now the Downloader’s “Download File” action will work on any file that we previously clicked the Link control for but will still not work for files we haven’t clicked it yet. It’s really bizarre behavior. Can somebody help me figure this out?


#2

Hello, @AZDryHeat.

Sorry for the trouble, however for a better troubleshooting could please screens of the workflow with more details for us to be able to replicate the issue you’re having.
Thanks for understanding.


#3

Sure, here are the steps to replicate the issue:

First create a Page with the following controls:

File Uploader
File Downloader
Link
Icon/Button

Now upload a file and attach it to a record with a Privacy rule that allows the current user to “View attached files”. In this example I used the standard File Uploader control.

When that upload completes click the Icon/Button that triggers the “Download File” action for the File Downloader control. I used the File Uploader’s URL value as the Dynamic link and the File Uploader’s file name as the File Name.

What I am seeing is that nothing happens. The workflow is triggered successfully but the “Download File” action doesn’t cause a file to be downloaded, also no errors are raised.

Now, if I click the Link control (which simply opens the File Uploader’s URL in a new window) the File opens successfully.

The weird part is that if I now go back and click the Icon/Button that triggers the “Download File” action it now works correctly and the file downloads. I have no idea why this is happening. Let me know if you need me to record a video of the behavior. Thanks!


#4

Dumitru,

Any updates on this? Let me know if you need anymore information regarding this issue. Thanks!


#5

@AZDryHeat hello and sorry for the delay.
We run the settings you’ve showed, but still may seem something off with the workflow.
I would like to recommend you add our devs: [email protected] as collaborator to your app and pinpoint to the page location with issue. Also please say the name of the app you’ve added us :wink:
Thanks for understanding.


#6

I have added [email protected] as a collaborator. The app name is “downloadertest” and the page which demonstrates the issue is “downloader-test”. Let me know if you can’t access it.


#7

@AZDryHeat, Hi.

We fixed the issue with plugin and pushed an upgraded to it, now it should work normal with privacy rules.
See your test app and give it a try now. Thanks for patience and understanding.

Regards,
ZQ Team.