Templates Plugins Courses

Easy Google JWT error

I bought the Easy Google JWT plugin and entered my JSON key as instructed (copied all contents of the JSON file where it says ‘Google JSON key file’) but every time I try to get the token, I run into an error. I recorded the error message in the video link here: https://share.vidyard.com/watch/GsBTqNYF642kAyYMqLdBmD

You can replicate it by clicking on the “Get Token” button on this page as well: https://ctwtoolbox.bubbleapps.io/version-test/test?debug_mode=true

Please let me know what I’m missing.

Hello @nashwa.alsharki, thank you for reaching out!

We will investigate the issue and will get back to you with an answer ASAP!

Best Regards,
Alex

@nashwa.alsharki,

Could you please add [email protected] as collaborators to your app. That will let us understand better the cause of the issue and how it can be solved.

Best Regards,
Alex

I don’t have a professional plan and so I can’t add collaborators that don’t have designer/agency accounts. Does zeroqode have an agency account I could add?

Hello @nashwa.alsharki

Let me jump in here.

Can you please replicate a simple demo setup, the likes of this: https://bubble.io/page?name=index&id=pwc-easy-google-jwt&tab=tabs-1&subtab=App%20Data
Please be sure to get the right scopes for the action, or simply replicate the one we have in demo.
Try this by creating a new key in json (service account type).
Thanks for understanding.
:pray:

Yes, we are on agency so it should not be a problem to add us as collaborator.

Regards,
Dumitru.

I don’t have permission to view the simple demo setup you shared…

That said, following your advice, I created another key and now the plugin is actually working. So I think it was an issue on my end. I’m sorry to have wasted your time and thanks for the help!

1 Like

Hi @nashwa.alsharki

Thanks for confirming it with us! Appreciate :pray:

Sorry for the trouble with demo setup, seems like we forgot to open the access for users to look at it.
:pray:
We’ll adjust this, shortly.
Thanks for understanding.