Templates Plugins Courses

EasyFile Downloader Broken

Hello,

Easy File Downloader broke down today across all browsers due to CORS permissioning from your HEROKU CORS Anywhere. See screenshots:

Access to XMLHttpRequest at ‘https://cors-anywhere-zq.herokuapp.com///s3.amazonaws.com/appforest_uf/f1634052886342x236559214131825570/Jourdan_R%20arm%20out_class%201.JPG’ from origin ‘https://goterracotta.org’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.
PLUGIN_Easy-File-Downloader-element_action–File-Downloader-Download-File-.js:65 GET https://cors-anywhere-zq.herokuapp.com///s3.amazonaws.com/appforest_uf/f1634052886342x236559214131825570/Jourdan_R%20arm%20out_class%201.JPG net::ERR_FAILED

Hello, @jacob2
Thanks for reporting this issue.

Please allow me to test the plugin and discuss this issue internally. I will revert with an update immediately after resolving the appeared issue :pray: Thanks for the understanding.

Best regards,

Thank you, @Ecaterina - any updates?

Hi @zeroqode1 @Ecaterina Hi guys, this is critical functionality broken in our production app; what’s the ETA on the fix?

Hello, dear @jacob2
We are sorry for the inconvenience you have faced.

Please note that the issue was already found and our Developer Team is working on a solution.
We will revert with an update to you on Monday but will do our best to speed up the process.

Thanks for the understanding :pray:
Best regards,

Hello, @jacob2
Thanks a lot for your patience.

By this message, I would like to notify you that the CORS permission issue was fixed. Thus, you can easily use the plugin within your application.
Please check it and let me know if it works on your side.

Best regards,

Hi, my app is having the exact same issue. I’ve already posted on Bubble so I’ll simply re-post my issue here on this thread:

I’ve currently got our web app’s download setup using Download Progress linked to a button using attribute ID.

This setup sometimes works but frequently gets the following error on our developer console:
Access to XMLHttpRequest at ‘https://fan2seevideo.s3-ap-southeast-1.amazonaws.com/fan2see/a8Kn7Mrtsl.mp4’ from origin ‘https://fan2see.fun’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

We don’t really recognize a pattern behind these errors, sometimes we get that error in the first 5-10 seconds of loading the page, sometimes the error never goes away. When this setup works, it works for most of the commonly used devices / OSs.

We’ve tried everything on S3, but we highly doubt it’s an S3 problem as we set CORS and access to basically no limit. The link also works when we manually visit the URL.

Update 01: The CORS problem doesn’t show up on Chrome PC, but shows up on MS Edge PC and Android Chrome so far. We’ll continue to add other device/OS here as we test.

Hello, @chou.wilson
I’m really sorry for my late reply here :pray:

Please note that this error was fixed already and now, the plugin works properly.
I’ve tested it from the mentioned browsers and the CORS policy error was not reproduced again.

Please check it and let me know about the result.
Best regards,

I just checked my android Chrome both today and yesterday, it seems to be very hit or miss. Sometimes it works sometimes it doesn’t, we’re not able to diagnose why…

Update: I just tried on Windows PC, Chrome browser, CORS blocked again:

Hello, @chou.wilson
Thanks for the details.

Can you please remove the plugin from the application ( and related workflows) and reinstall this plugin within your application.
Unfortunately, this issue Is could not be reproduced from our side. Thus, we need to understand if it will be reproduced after complete plugin reinstallation.

After it, please check again your application and let me know if the issue will be reproduced. I will do my best to assist you further.

Best regards,

We just tested things again, everything seems to be working now except on iPhone’s Safari browser. It still downloads, but it’s just very, very laggy.

The other OS/browsers all have a 2-3 second lag before the download pops up.

Hello, @chou.wilson

Please allow me to check the plugin behavior on the Safari browser with our team and to revert with feedback. Thank you!

Best regards,

Hello, @chou.wilson

Please note that we have checked the plugin performance using the different models of iPhone ( on Safari browser) and I’m afraid that the loading speed was pretty high (the video was uploaded in 3 seconds).

Note that the Safari browser is not so fast, like Chrome or Firefox, so speed can be a bit lower, however, it does not affect the plugin’s work.

In case any plugin-related questions will appear - let me know.
Best regards,

Got it. Is there anyway you guys can mitigate this issue? 3 seconds is a long time in today’s world.

Hello, @chou.wilson

Please note that we can’t influence the browser loading speed, because it is not our product :slightly_smiling_face:
From our side, we have done everything possible to make downloads as fast as possible for each browser. However, as I noted earlier, the Safari browser is not so fast as others.

In case you will face any additional issues with the plugin - please let me know.
Best regards,

It’s been a couple of weeks - the download was working OK with a not so great but acceptable lag time of 3-5 seconds. Now it’s lagging a lot more, especially on iOS devices, sometimes up to a minute.

I can confirm that it still laging on Android too.

Hello, @chou.wilson and @kennyomegaxman1
We are sorry for the inconvenience you faced with this plugin.

Allow me to mention that we have tested the plugin from different devices and browsers (the same as the different OS), and the speed of the loading is pretty high.
Compared to other browsers, the slowest speed is only observed in Safari, however, the difference is in 1-3 seconds.

This behavior could be affected by the works of the Bubble Team, so they could slow down the application performance.

Sorry for this inconvenience.
Best regards,