Templates Plugins Courses

Emails and links are cut off

Links and emails are cut off in the plugin ‘Advanced Rich Text Editor’. Could you please help me?

Hi @bulat.akhmadeev,
Thank you for your message and for using the Advanced Rich Text Editor Plugin.

Currently, the Plugin has a feature to Auto Detect URL and converts them to Hyperlinks if such an option is set to Yes in the Plugin element.


I can check with the dev team if it is possible to add an improvement to the plugin to auto-detect emails when @ sign is used.
Once there will be any updates, I will notify you.

If you require any further information, let me know.
Best regards,

Hello Igor,

thank you for your answer! If I needed only emails it would help, but I need also to have correct links, that are also cut off sometimes. Could developers maybe add an improvement to the plugin to auto-detect links when all possible top-level domains (such as .com, .net, .org etc.) are used? Is it possible to make too?

And I got second problem after I’ve followed you recommendation: I’ve set ‘Auto Detect Url’ to “no” and ticked the checkbox ‘Link’, but when I type some text and then paste an external URL (for example: www.apple.com) and click then on the link after posting, this external link is put after an internal link (for example: https://app.animals.com/version-test/tiger/www.apple.com), so it doesn’t open the link. But is happens not all the time, depends on the link. Is it also a bug in Advanced Rich Text Editor Plugin or can I do something by myself to make it open correctly?

Here are 2 videos about problem:

Thank you in advance for your answer!
Best regards,

Hi @bulat.akhmadeev,
Thank you for your reply.

I’ve carefully checked the above videos, if the Auto Detect URL is set to NO:


then your URL should contain HTTPS protocol in order to be open properly, usually, when you copy an external link from the browser tab (https://www.zara.com/ / https://www.apple.com/) and paste it into the redactor you will see:

With this format of the link, it will open properly.

In case the Auto Detect URL is set to Yes, then copy-pasting URLs from external websites will convert the text into an URL automatically:

or if you would like to type the URL manually you should insert www in front of the webpage as the example below:

I’ve checked other domains, and the Auto-Detects of URL works as it should, please make sure to use www in front of the link.

Hope the above will be useful for you.

If you require any further information, let me know.
All the best, :slight_smile:

Hello Igor,

Thank you for your reply!

Unfortunately, when Auto Detect URL is set to YES, links are not always recognized correctly, sometimes they are cut off (for example, if I open the link with ‘/version-test/’ in it, this and all what comes after it is cut off). Therefore I set it to NO and enable the possibility to add link manually.

Users of the app sometimes type website-addresses manually and don’t add ‘https’ in the beginning. As a developer, I can understand all plugin’s rules and restrictions, but the app and the plugin are used by ordinary users of the application, so it would be great to add a possibility to the plugin to just recognize links in all their variations (as you offered with mails by recognizing @). For example, what I offered before, it could be set up by recognizing all top-level domains (such as .com, .net, .org etc.). Or at least hints could be added for users in what form links should be added to be opened properly. When the user adds a link like ‘www.zara.com’ and see this address by adding the link, the user doesn’t expect the hall app-address in the beginning of it by opening the link, so the user even doesn’t know sometimes, that there is some problem with the link.

We really like this plugin and would love to see it get better and more user-friendly!

Thank you in advance for your answer!
Best regards,

Hi @bulat.akhmadeev,
Thank you for your reply.

Unfortunately, I wasn’t able to reproduce the above issues on my side, attached a Loom video where you can see that the Auto Detect URL works as expected.

Can you please check the plugin version you are currently using, in case if it’s an old version, try to Update to the latest one and see if it will work differently. Remove the ZQRte element from the page, and place another one after updating the plugin.
Also, let me know the Bubble version your app is currently on.

In case the issue still persists, please record a Loom video in step-by-step mode with the browser’s console enabled, in case there are any error messages there, and share a link with us so we can understand better your use case.

These details will help us reproduce your setup on our side and look into it.

Thank you once again and looking forward to your reply.
All the best, :slight_smile:

Hello Igor,

Thank you for your reply!

I’ve updated the plugin to the latest version and removed the ZQRte element from the page, placed another one after updating the plugin, as you asked. The situation changed, but there are still some issues in the plugin:

  1. Although email-addresses look good, by hovering some of them are divided into 2 parts.

  2. By clicking on email address, the app-website with the email address (or some part of it) in the end is opened.

  3. I think it would be great to do something with the https protocol: at least make some hint for a user by clicking on the icon to add a link to the text, that for opening properly the link should contain ‘https’ in the beginning, and remove the function of auto-detecting URL if the link can’t be opened properly.

The issues you can see on the video:

I look forward to further discussion and suggestions on solutions to these problems.

Thank you in advance for your answer!
Best regards,

Hi @bulat.akhmadeev,
Thank you for your reply.

I’ve added already to the Plugin Improvements list a new feature to auto-detect and convert email addresses when @ sign is used.
Our dev team will check how feasible it will be to include this feature request in the next plugin update, but currently, I cannot provide any timeframes, since this feature request is at a low priority.

As a workaround, I can suggest you use the Auto Detect URL feature only for URL’s, once this option is enabled and you copy an external link it will be pasted correctly into the editor, if you type the link manually, mandatory use www in front of it.
As for email addresses to work properly, you have to select them and click on a hyperlink from the toolbar, where you will see the correct format for the email address hyperlink: mailto:someone@example.com

Please find attached a video with some examples:
https://www.loom.com/share/d6a8022268b54fb69bc2d0b6c6c350aa

Once I will have any updates regarding the email addresses auto-detection, I will let you know asap.
Thank you for your understanding and cooperation.
Best regards, :slight_smile:

Hello Igor,

Thank you for your reply!

Got it. And what about https protocol and url-addresses? Is it planned to do something with it in the future? *Regarding the clause number 3 from my previous message:

“I think it would be great to do something with the https protocol: at least make some hint for a user by clicking on the icon to add a link to the text, that for opening properly the link should contain ‘https’ in the beginning, and remove the function of auto-detecting URL if the link can’t be opened properly.”

Thank you in advance for your answer!
Best regards,

1 Like

Hi @bulat.akhmadeev,
Thank you for your reply.

I’ve passed this information to the dev team, once there will be any updates, I will let you know asap.

Thank you for your understanding and cooperation.
Have a great weekend ahead.
Regards, :slight_smile:

Hi @bulat.akhmadeev,
Thank you for your patience. :pray:

I’ve carefully checked with the dev team upon your request to auto-detect emails, we did a few tests but unfortunately, it is not possible to implement this feature without breaking the plugin logic.

Basically, the Auto-Detect URL feature continues to work only with links, and please remember if you type the hyperlink manually you should insert www in front of it, on the other hand, this is not required when you copy-paste the links into the editor.

For the email addresses please use the Toolbar element hyperlink, this will convert the email accordingly with the mailto: prefix.

If there will be any other plugin-related questions, feel free to contact me, I’ll be glad to help.
All the best, :pray:

Hello Igor,

Thank you for your reply!

I see, it’s a pity. And what about https protocol and url-addresses? Is it planned to do something with it in the future? *Regarding the clause number 3 from my previous message:

“I think it would be great to do something with the https protocol: at least make some hint for a user by clicking on the icon to add a link to the text, that for opening properly the link should contain ‘https’ in the beginning, and remove the function of auto-detecting URL if the link can’t be opened properly.”

If emails are detected incorrectly and are cut off when the Auto-Detect URL feature is enabled, then enabling the feature is not an option for us. Or is it possible maybe to make auto-detection work only on links, but not when entering email addresses (I mean, not to detect ‘gmail.com’ as URL and to separate it from another part of email address)?

Thank you in advance for your answer!
Best regards,