Templates Plugins Courses

[error] Algolia Places stopped working after the update


#1

After the update the auto complete/ suggestion is not working anymore.

This happens ONLY when I upgrade to the latest version

Thank you


#2

Hello!
Thank you for contacting us! I’ve just checked the latest version and it works fine:

Could you try to move the plugin 1 pixel left - 1 pixel right. Sometimes after the upgrade the changes don’t initialize immediately and this little hack helps.

Regards,
Olga


#3

Thanks for your reply Olga but still not working

CloudApp


#4

Thank you for the video! I’m sorry but I didn’t see the issue as you didn’t start typing in the address field. The autocomplete/suggestion is activated when you start to type the address. Could you please check that it doesn’t work when you enter at least a letter into the address field?
Kind regards,
Olga


#5

Its doesn’t work when you type (autocomplete doesnt work after the update). If you watch carefully you can clearly see that the textbox even looses it’s style.


#6

Hello!
Could you add [email protected] as a collaborator to your project please, tell me your app name and the page where the problem is and I will check it from the inside.

Kind regards,
Olga


#7

Done. App name is: AreaVIPAPP
Page name: Reusable: Perfil-Update

or page: relatoriofaculdade

Thank you


#8

Thank you! We’ve seen it. Could you please keep the old version for now and meantime we’ll fix the bug and let you know.
I’m sorry for your inconvenience and thank you for letting us inside your app.

Kind regards,
Olga


#9

sure, no problem.
Thanks Olga!


#10

Could you add [email protected] to collaborators too, for our devs to see the console errors please? Thank you in advance!

Kind regards,
Olga


#11

Hi Olga!
I just added you as collaborator.
Thanks


#12

Thank you for reporting a problem! We’ve updated the plugin to fix the issue. Your plugin version is up to date already, we’ve checked that it works in your environment.
Please note that you should add API key and app ID to the plugin settings:

Sorry for inconvenience, please contact us if you have any other questions.

Kind regards,
Olga


#13

Hello Olga, for me still not working. Now the field doesn’t even show up.

Just to confirm, are these the keys that I need?

Thank you


#14

Hello, @caioprezia

Dumitru here!
Please check your app in dashboard.
A Places app ID starts with pl to distinguish them from regular Algolia apps.

Algolia Team update Places landing page and documentation to avoid this confusion. But just in case, you need to create a Places app and do no reuse your previous regular
apps:

So check the links for Places documentation and in dashboard for Api Key and APP ID.

Regarding the issue with plugin settings inputs, would recommend you uninstall and re-install plugin, place the algolia places element on page, refresh the app and give it a try.

Best,
Dumitru.


#15

It’s working now. Thank you Dimitru!