Templates Plugins Courses

Error text editor save content


#1

Hey all, @Nikita.S

We are building a SEO app helping people in writing better content and keeping track of their articles.
When the user opens an article ans start taping, after 30 seconds, the cursor go straight down to the bottom of the page.

We set up an automatic save after 30 seconds.

here is how the text editor is setup

here is the video of the editor

how can we fix it so the cursor don’t go all the way down ?


#2

Hey @jv.hirigoyen,

Check this post, it should help you to fix this bug.

Just in case if it not, tell me please does the Auto-save makes changes in Database successfully?

And also could you please provide the details of Browser, and OS which you are using on the Video.

And add [email protected] as a collaborator to your app, and pinpoint the location where the issue is.

Thank you,
BR.
Nik.


#3

the autosave works but the cursoe goes down.

Google chrome on windows 10.

The location in on page “aide_redactionnelle”, the RTE is called RTe and the workflow I am using are in purple.

Looking forward to hearing from you


#4

Hey @jv.hirigoyen, so we found a bug, our team fill fix it asap, i will update you of a metter.

So wile the bug is fixing you can evade it, for this you just need to select this checkbox, and it will work alright for you.

Thank you,
BR.


#5

Thanks.

One other problem: THe editor tends to make the page crash after a few minutes of writing on MAC


#6

Hello @jv.hirigoyen so we fixed bug with the scroll, you can check it now.

About second one can you give me the error details, so open your app in debug mode and share with me a screenshot. Or pinpoint your steps which lead to crash. I will reproduce it.

Thank you,
BR.


#7

Hey Nikita,

I create a page, enter the information, start taping in the edtior. After a couple of minute, the following screen appears.


#8

@jv.hirigoyen can you please to make the same actions, and when this page will appear tape ctr+shift+i, open window Console and make screenshot for me.

Thank you,
BR.


#9

@jv.hirigoyen So we made changes at your workflow in app, because the page crashes because each 2 seconds was enabled autosave and this lead to heavy load on the application, now we change on each 30 sec and it works fine, the text will be saved after 30 sec after typing.

Test it please, and give your Feedback.

Thank you,
BR.
Nik


#10

Seems better.

I guess I might have some issue if too much users connect in the mean time, right ?


#11

@jv.hirigoyen

Now i don’t think so, because your “Server” is Bubble cloud, so you don’t have to worry about this.

But i suggest you to check out our courses maybe there are some what will be suitable for optimisation of your web site.


#12

Thanks Nikita,

Still it is crashing o Mac book pro. WHY ?


#13

Hey @jv.hirigoyen we still can’t catch this one issue, can you please open your app in debug mode, press step-by-step and record a video like this, and when the app will crash open console window in inspector(to call inspector you have to press cmd+alt+I), i want all the info will be in Video, in this case everything will be clear for us, and we will help you.


#14

Hey @jv.hirigoyen, so i faced the same issue but with another app, the problem is in the Memory which your site is uploading to cache each time when you working with your web-site, It’s happening because of two reasons:

  1. First one is that your app is deployed on Bubble cluster servers, if it is affordable to you, you can change your plan for the app will be deployed on the dedicated server.
  2. Second one is that you don’t have enough RAM on your MAC, and here my suggestions is to optimise your app, for decreasing the workload for the final user of your app, and to Upgrade your computer, to add additional RAM.

Thank you.
BR.
Nik.