Templates Plugins Courses

Fastest Google Places Autocomplete Not working


#1

Hi i have been trying everything to make the reason this plug in is not working is not my fault. I think there is a bug or an issue with my subscription causing this not to work or i’m just missing something?

I’ve done everything from remove everything off my page and only have the input field, the map, and the extension to copying everything from the example to my page and i am no getting a drop down with suggestions when i type.

I did uncover 2 possible critical missing steps that should be documented in the instructions and hope to uncover another in this topic with help.

1.) I have to have a paid plan in bubble to use this app, i was on the hobby version and changed to personal as a last test to see if that was it but still doesn’t work but not sure if that led to issues per the image below?
2.) in order to add the ID Attribute you need to allow this in the settings>general>Expose the option to add an ID attribute to HTML elements

Here is a screen shot of the element page which seems wired that it would say resubscribe after i paid the full amount vs monthly.

Hope someone can help make this headache go away.


#2

Hello @chris2

I would recommend you to follow all our documentation, demo setup which shows examples how to use the plugin and it is set. It should be pretty much straightforward: https://docs.zeroqode.com/plugins/fastest-google-places-autocomplete

If there are issues with your billing , I recommend you to submit your query to Bubble: https://bubble.io/contact
Hope this helps.
:pray:

Regards,
Dumitru.


#3

Hi Dumitru, That is what i was thinking pretty straight forward so when it didn’t work as the demo does I literally went through the documentation you linked to 20 times before posting to this forum.

Is the resubscribe button supposed to be there if the subscription is active?

Is it true that in order to use this extension you can not be in the hobby version of bubble?

I’ll reach out to bubble once i hear back from you.

I’d suggest adding to your documentation (in order to add the ID Attribute you need to allow this in the settings>general>Expose the option to add an ID attribute to HTML elements


#4

@chris2 hello!

I’m afraid I don’t know about this, it’s more a of a framework related question which you could check with Bubble. (https://bubble.io/documentation)
However if your plugin subscription is active, I believe it should not be available.
But better to check with Bubble

To answer your question,

People can buy perpetual licenses for plugins on a one-time basis for apps on a Hobby plan. (For technical reasons, it’s hard to do subscription-based plugins if the app is not already on a plan).

The quote is taken from the additional link below.

I would recommend you to read this topic about plugin licenses and how they work : https://forum.bubble.io/t/new-feature-one-time-payment-model-for-premium-plugins/34858
Additionally read the latest update on plugins here : https://forum.bubble.io/t/pricing-updates-and-thoughts/64515/101?u=zeroqode

Pretty much all the question related to billing of Bubble Framework, I recommend you to check with them.
Thanks for understanding.

Thanks for the feedback we’ll improve the documentation.

:pray:

Regards,
Dumitru.


#5

I figured it what was causing my issue.

It was on the Google Cloud Platform side. I had restrictions on which key’s to use selected APIs. Which did include Directions, Places API in Google Cloud Platform and more.

When i took off API restrictions then it worked.

There must be one of the APIs needed for this plug in that is not in there or by doing this it knocked something loose.