Templates Plugins Courses

Following your really good guide on service account setup and yet


#1

Dear @levon & @Dumitru,

I bought the Google Sheets service account plugin and I want to start by saying I have followed your guide https://docs.zeroqode.com/plugins/google-sheets-and-charts-service-plugin/obtaining-service-account-keys
and it is pretty darn clear even for a non-technical user, good work on the tutorial!

This is why I feel extra clumsy… because after filling everything out and walking trough it, when I try to do the easiest command in Bubble ( create spreadsheet) I get a ‘Sorry, there is a temporary bug’, so I guess something went wrong in setting up the plugin.

So, what did I do:
I enabled the Google sheets APi ( and google drive api for good measure) for project I made:

I think I made a serviceaccount for that project:


It was given ownership level clearance for the project

I then made a key based on JSON.


Out of which I took the email address and subsequently adjusted the Private key to take out the \n and =
Endresult here

With the changed private key according to the instructions here (where a very large amount of letters have been replaced not to give away the key but the form has remained the same for the troubleshooting):

Because I think I now did the process 5 times trying to figure it out and I end up with the same result, can you help me out?

Kind regards!


#2

Hi guys ( @levon, @Dumitru , Have a suggestion?


#3

Hi there, @waviourwave

Sorry for a delayed response, would recommend you check out the demo page as well:


and the editor page how we set it up with plugin actions including creating a spreadsheet:

Also post details of your workflow setup, screenshots maybe a video demo of issue (useloom.com) an ok tool for recording.

Regards,
Zeroqode Team.


#4

Hi Dumitro,

Thanks for the response. I checked your Editor version. Plugin settings * looks* the same as my setup.
The workflow of the ‘Create Spreadsheet’ looks simple, which is why I chose it to test if I installed the plugin right:

When I push the button I receive a ‘Temporary bug’ notification.
How can I get it to work?


#5

@waviourwave the only way I see it for us be able to debug it is by adding [email protected] and [email protected] as collaborators to your app.
Create a demo page and copy it from current page setup with workflow/settings, pinpoint us where it is so we could try test it and debug it.


#6

HI Dumitru.
I added the mails as collaboratours.
Demo: here

I also tried to add you to my project on google, because perhaps I did something wrong there. However, for that, I would not a Google ID of you.

Anyway, Really hope you figure it out, let me know you need anything else.


#7

Hi, @waviourwave

Sorry for a delayed answer here, let’s us check the app and try debug in it.
Thanks for understanding and patience.

Regards,
Zeroqode Team.


Update

I think we did not understood each other here. I see that the demo app is a copy from your main app I presume, which is on hobby plan. Now I can’t test the plugin actions since it requires at least personal plan (paid plan) to use the plugin.
As you see in screenshot below, the app demo you provided access to is on hobby plan:


#8

@Dumitru I indeed misunderstood.
I added you now to the original app ( on Personal plan), with a created demo page here.

Thanks for helping out. Let me know if I should add you to the Google Console.


#9

Hello @waviourwave.

Checked the app and tried the guide which was somehow unfinished, sorry about that. Have updated the guide as well to reflect the changes required for you to be done (https://docs.zeroqode.com/plugins/google-sheets-and-charts-service-plugin/obtaining-service-account-keys)
When you create the service account, you need to give 2 roles to it one of a Owner another is as Service Account Admin.
No need to worry, now just head to your Google Cloud console and add second role to current account as shown in screenshot:

Note, it may take some time before the changes are in place so please wait before trying actions after this.

Also would recommend to double check the key. Remove all the new lines “\n” and equals “=” symbols from it as shown in google doc.

Hope this helps.

Regards,
Zerqode Team.


#10

Hi,

Thanks, good to know it was not all clumsyness from my end. The \n and = should have been removed from the key already.

I think I got it:

I wil check in two hours if it works. Thanks!


#11

Hi Dumitru,

I added the role acording to the instructions, I redid the Private Key to be sure ( Replacing \n and = also again)…yet I still have the same result unfortunately: ‘Temporary bug’ :S


#12

@Dumitru, Goodmorning! How to proceed now? DOes it make sense if I include you via de Google Console?


#13

Hello @waviourwave

Sorry for a late response. I would recommend to file a bug report to bubble: www.bubble.is/bug_report to file an official bug.
Also maybe try uninstalling, refresh the app and installing plugin again to give it another try.
I did same steps as written in instruction and no issue whatsoever with keys.
Thanks for understanding.

Regards,
Dumitru.


#14

Hi Dumitru,

Isn’t is much more likely then somehting is just not accurately done by me on the Google console, then that this is a Bubble error?
Did you check the workflow that was setup by me?


#15

@Dumitru
Also, how can I debug this? SO right now, I do the entire process, then set up a workflow to create a new spreadsheet in Google sheets, I press the button which should trigger the action and I get the temporary bug signal.
Is there a way to just check if the Plugin is working?


#16

@waviourwave
You could try enable Bubble Debuger - adding ?debug_mode=true in URI
and see a step by step process:


Hope this helps.

Regarding the workflow I checked the app and created in the app a copy of our demo workflow so pretty much tested same scenario.

Still I would recommend you open a trouble ticket to bubble.


#17

ok, But if you IN my app did a copy of your demo workflow and it works, then it isn’t an error on bubble side, right?


#18

Hi.

Narrowing down it may be the rsa key is what is causing the trouble. The \n removal should not add any spacing or other characters removed.
Please check the key or create a new one which will work correctly. Testing the key you’ve generated, seems like still an issue.
Also if you could pm me you full unedited JSON key so could check it.

Best regards.


#19

For future users struggling with the Private key. @Dumitru managed to figure out why the key was not working:


#20

bravo @Dumitru :slight_smile: