Templates Plugins Courses

Fuzzy Search Broken. Other Forum Posts not helping

I can’t get Fuzzy Search to work despite copying your format in the demo and copying Buildcamp Greg’s setup video.

Here’s the screenshots of the setup and resulting search return.







Any input would be greatly appreciated! Thanks!

Brian

Hi @brian3, thanks for reaching out.

Let me try to help you.

My guesses are that your Threshold (0.9) is too high. Try to change it to 0.
Search&Autocorrect A has 5 Fields To Search, they should match the fields that are in your database (for instance User type has field type name, age, email… you can search via them). Also, the ID of the Plugin should be the same as the ID of the input element.

Please check the screens below to see my settings for this plugin to work properly. And let me know if this was helpful for you.

Regards,




@Igor thanks for replying.

I tried everything from 0.1 to 1.

I put 0.9 in the photo to show that I had read the documentation and that I knew that 0.9 should catch more possibilities, not fewer.

Hi again @brian3 , sorry to hear about this.

Can you please send us some screenshots of the data types you are using, as I see in Fuzzy Search Plugin:
1. Field to Search 1 is Search$name.
2. Field to Search 2 is Slug.
3. Field to Search 3 is Unique ID.
Do they match with the data type’s name and with the input value?

In other words, the input value should be the same as the Field of Search data type you are searching for. Hope the above is useful for you.

Regards,

Here’s the makeup of the Search data type

I don’t know what you mean by “Do they match with the data type’s name and with the input value?”

If you check the last 3 screenshots…

…in the first you are seeing a list of all of the searches

The list has just the $name and the ::datatype:: in the repeating group.

For example, in the 3rd last screenshot you can see “Velocity Metrics” as the third down in the list.

Despite having maximum search breadth and minimum “ignore below” setting, and no capitalization rules…

… in second last screenshot you can see “v” is not bringing anything up and

… in the last screenshot you can see “velocity” is not bringing anything up.

Hi @brian3 , thanks for your response.

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:
Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,

OHHHHHHHHHHHHHHH OKKKKKKKKKKKKKKK

I figured out the problem.

I didn’t have the plugin in the same group as the input box.

That may be a bug in the new responsive editor or was like that the whole time, dont know

SO!

Solution if plugin isnt working right away is to make sure it is in the same group, or I am thinking perhaps a group where it is discoverable? :man_shrugging:

Something like that :slight_smile:

Thanks for offering to give it a go and for taking my messages! Put this one in the FAQs!

2 Likes

Hi @brian3, thanks for your message.

That is amazing, I’m really glad that your app is working properly.
Thanks for that tip.

Have a great day!
Regards,