Templates Plugins Courses

Fuzzy Search Not Populating Correctly

I am having several issues with the fuzzy search plugin. For some fields, it does not search beyond 2 characters (for example, I’m trying to search “luxury”. When I type “Lu” the results appear, but when I type “Lux” or more, the results disappear. In another instance, I am searching a second field using the term “Washington”, some of the matching results are missing. Any assistance would be appreciated.

Hello, @erinwashington50
Thanks for using our plugin.

In order to provide you with a more precise answer, please share with us the screenshots of your current settings for the next elements:

  • Plugin element;
  • Related repeating group;
  • Input (and it’s ID).

Looking to hearing from you soon.

Best,
Gulce

hi @gulce.besel - see screenshots attached. thank you for your help.


Screen Shot 2022-07-29 at 10.04.17 AM


Screen Shot 2022-07-29 at 10.05.30 AM

Hi @erinwashington50,
Sorry for the late reply due to the weekend. :pray:t2:

The plugin allows choosing from any data source, searching for not-perfect matches accounting for typos and close/perfect matches.

In case of the default settings for the template, please note that currently, it is set the Perfectly match Threshold.

Summary

Number 0 means that the plugin requires a perfect match.
If you need a non-perfect match, just use 1, instead of 0.2

If the issue still persists, would it be convenient for you to share access to your app so I can take a look?

For this please add our support@zeroqode.com email as a collaborator of your app (disregard the warning, our email can be added to the collaborator list even if your app is on the Free plan). And please let me know the page name where the issue is found.

Looking forward to your reply.

Best,
Gulce