Services Plugins FAQs

Fuzzy Search not working suddenly

Hi Team ,

I noticed that fuzzy search on my app suddenly stopped working. I went through few threads and checked if I have setup things properly. I even tried changing the version and test, but it didnt work. Here are pictures of the configuration of Input, AutoSearch & Repeating group. Can you please help me figure out the issue and fix

Screen Shot 2566-05-23 at 14.53.19

Hi @mayank.m84, thanks for reaching out and providing screenshots.

Regretfully, they are not enough for identifying the issue cause. Please share a screencast (I recommend using the Loom tool) with the RG, input, and plugin element’s whole setup.

Also, allow me to recommend using the workable setup shown on our demo editor page as a setup reference.


Hi Serg,

Thanks for the quick response. Here a loom video recording for your reference - Loom | Free Screen & Video Recording Software | Loom

I couldnt access the demo editor page you shared, I dont have permission to view it.

Look forward to your reply

Hi @mayank.m84, thanks for the screencast shared.
I will check it with the developers’ team.

Sorry for giving an inaccessible link, let me check what could be the cause.

@mayank.m84, the developer team checked and would like to share the recommendations below:

Please check the following moments:

  • if the element id used in input/plugin element - fuzzy - is not repeated elsewhere or doesn’t contain an excessive space before or after ID.
  • please change the “Threshold” value from 0.2 to 0.5, to see if it will help.

In case both pieces of advice will not help, please add our Support Team email to the list of collaborators to your application and provide us a link to your application (as well as let us on which page and under which user we can replicate your case).
This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:
Settings > Collaboration > Add email

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.


. I tried the sugestions you provided , but that didnt solve the issue. Is there a way for me to search by element id throughout the workspace?

Unfortunately, I can’t add any other collaborater under the current plan either :frowning: . IS there any other way you can help . Maybe get on a google meet and I can share my screen

Hi @mayank.m84, thanks for your reply.

I’m afraid that Bubble Editor doesn’t provide such a feature, regretfully.

We provide support in written form only, sorry for possible inconveniences.

Please note that this feature is available on any plan, as the invited email refers to an agency (us).

Looking forward to your reply.


Hi Serg,

Sorry for the late response. I’ve added the support team as a collaborator today. I used the fuzzy search on page called “dispensaryMenu”. Please note that I hid the search field as it wasn’t working.

Look forward to the next steps. Happy Friday!

Hi @mayank.m84, thanks for your reply.

I’m afraid that as the plugin element is missing, I could not proceed with the testing.

If the setup will change and you will use our plugin again, please let me know.


Hi Serg,

Hope you are keeping well. We added the Fuzzy search again, and it was working fine.

Last week we added couple of new elements on the page in the DEV environment. While testing we noticed that the fuzzy search isnt working any more. The fuzzy search works on LIVE as we still have not deployed the changes.

Can you have a look and let me know the root cause.

Page : DispensaryMenu
Element : Input FuzzySearchStrain

Hi @mayank.m84,
It’s Gulce from the Zeroqode Support team. Let me please jump in here.

I’ve tried to check the preview to see the result but unfortunately, failed. Could you please share a video recording so I can understand how I can reproduce the issue in your app? Which user credentials can I use, and what steps do I need to take to see the issue? (here or via DM)

Also, could you please upgrade your plugin to the latest version and let me know if that helps? :pray:

Thank you! Looking forward to your reply.

Hi Guide,

Thanks for jumping in. Here are the environment links to view the BetterStoned - Weed Dispensary Menu

Recreation steps

  1. Open the Dev link
  2. Click on “Find My weed” search bar
  3. Type a Strain Name to filter from list of weed strains in the shop

Strain Card with Name

Expected behavior
User should see the strain that have names similar to the one user searched for.

Actual Behavior
The search doesnt filter. User see all the weed strain in the shop

Please note if you try the same steps in LIVE environment , the fuzzy search works.

I hope this helps. I’ll make a video if required.

Hi @mayank.m84,

Thanks for sharing those details!

I took a look at your app, and I noticed that the plugin element isn’t visible when the page first loads. So, what I did was create a test page called “zq_test” within your app. On this test page, I set up an action to make the plugin element visible as soon as the page loads.


You could actually make the plugin element visible right in the element properties. But using an action to show the plugin element on page load is a bit of extra insurance. It ensures that the input element you’re using for searching won’t load before the Search & Autocomplete (plugin element), which can sometimes cause issues.

Everything seems to be running smoothly now. Could you please check out our test page and replicate it on your main page?

Looking forward to your reply. :slightly_smiling_face:

Best regards,