Templates Plugins Courses

Gantt Chart Not Working, missing critical field


#1

I’ve purchased the Gantt chart and haven’t been able to get the chart to render although i ihave followed the documentation and copied exactly the set up of the demo. The header appears, but no graph. The other post suggests that every field must be matched to a data element or this error will happen, the problem is that the plug in is missing a field. I have uninstalled and reinstalled multiple times, but the “Task Depend On” field simply isn’t there.


#2

Hello, thanks for reaching out!
Try to reinstall the plugin, create a new page and copy the plugin element there.
Have you checked the plugin documentation page, it can be very helpful in resolving your issue https://docs.zeroqode.com/plugins/gantt-charts-plugin .


#3

Vitalie, as i said in my orginal post - i have both read all of the documentation, followed it exactly, installed and uninstalled several times (on new pages and existing pages). I belive the problem is that the field is missing from the plug in. CAn you confirm that the correct version of the plug in is published. I suspect there is a problem with the versioning and the “Task Depend On” field was inadvertantly deleted by the zerocode developer.

Please look at the picture I attached in my post, it shows where the plug in differs from everything in the documentation and in the demo.


#4

Hello again, excuse the previous question it was quite in excess, but now, more importantly, please check which version do you have in your bubble plugins tab, and if you have the option to upgrade please do so. If it still doesn’t work please report back and then we’ll check it on our side what seems to be the problem.
Best regards, Vitalie.


#5

I am on version 1.2.0 and there is no option to upgrade/update to a different version.

My application is currently on the paid platform “personal” is it possible that I need to upgrade to “professional” for this plug-in to work? Nothing in the documentation says that, but maybe it’s a factor.


#6

Hello, If there is no option to update, then there is no update. However if your version is 1.2.0, the same as in the demo, which does have this option included as in the screenshot image , So this could be an issue of bubble, let us check and get back to you asap.


#8

Hello again, @lpeters !
To correct this issue you need to have an additional column in your application data, for this field to display.
See our database setup:

Also we provide the documentation for reference to guide you.
https://docs.zeroqode.com/plugins/gantt-charts-plugin

Thanks for understanding. :pray:

Best regards,
Vitalie


#9

Thanks, looks like I had the field as a text, rather than a list of texts. evrything is working now.