Templates Plugins Courses

Gantt chart Plugin setup issues

Hi all,
I’ve been working on trying to setup the ZeroQode Gantt charge plugin for my Bubble application. I’ve review the documentation and the demo to try and match up everything but I have not had any luck.

Right now the chart displays the following.

Here is how my data type is currently setup to accommodate the plugin (this data type is being used in other areas as well so there are some fields that don’t pertain to the chart plugin)

Here is an example of the data that sits behind the data types

Any help on this would be amazing!

Hi @jasontrueblood,

Thanks for reaching out. Could you please describe the issue with more details, like what you are trying to accomplish or the plugin’s expectations perhaps, some screenshots of your plugin settings as well, browser and OS you are using to develop your app. However, without knowing more about your settings, I can give a hint that might help. Please check the plugin’s documentation and follow the steps, to make sure it’s been configure properly.

As a best practice, it would be best to create a separate type for tasks in Bubble DB, for ex. “Task”.

You could also check our demo editor and perhaps try to replicate on your side, then see if it works. However, if you still experience the same or any other issues, it would be best to share more details as mentioned above, so we can better understand the problem and come back with a working solution asap.

Thanks :pray:

Best,
Alex

Hi Alex,
Appreciate you getting back to me on this. The goal with using this plugin is to display a specific clients project milestones in a ‘timeline’ style Gantt chart. So I’m trying to the milestone name on Y axis and the duration of the milestone on the X axis. I thought I could use the same data type as the original milestones since the same data is being used. I thought about creating a new data type for the milestone data but I didn’t want to create the same data in two different places.

I already checked the demo editor and matched the data types and I also spent a lot of time reviewing the documentation.

Here is the chart setting


Here is how I’m calculating duration
Screen Shot 2020-06-01 at 7.22.18 PM

Here is how I’m creating ‘Parent’ and ‘Label’
Screen Shot 2020-06-01 at 7.23.23 PM

If this isn’t enough information to assist, please let me know what I can provide to help.

Thank you,

Hi @jasontrueblood,

Thanks for your feedback. We have tried to reproduce this issue on our side, and we might’ve found the reason that causes the issue.

So, you should be good to go even with your existing data type, meaning it’s not mandatory to create a separate one specifically for the gantt chart. However, you just have to make sure that all fields match each other with plugin element settings.

For this one field:

image

I cannot find it in your database based on provided screenshot, unfortunately. But, it should not be an issue as this is an optional filed. If you need this data, just make sure it’s present in your database and it’s of type text.

Based on the following provided screenshot:

I can surely say that this is the reason why your gantt chart is not displaying any tasks. The Label field is a required one, so if you leave this field empty while inserting new records into your database, the gantt chart will ignore the task.

Please do make sure that when you create new records, you actually fill in with data for REQUIRED fields, based on our documentation.

Hope it helps.

Hi Alex,
Thank you for looking into this. I’ve reviewed the documentation again and updated the database accordingly

However the chart actually reverted from what it was showing me to a completely blank box in the bubble preview.

This leads me to think there is something wrong with how the data is being pulled into the chart. Do you see anything wrong with my search function that would prevent the chart from pulling in data?

Hi @jasontrueblood,

Thanks for your feedback. I can see that the Label value has been respected. Other settings seem to be correct. However, after another round of testing and checking on documentation, I have noticed that the Type value for data records is with its first letter in uppercase. It might seem to be intuitive, indeed, but I’m afraid the plugin ignores it, because the actual valid values for this field have to be: ‘task’, ‘project’ or ‘milestone’, which are hardcoded in lowercase.

Also, I think this might be the causing issue as well, as I’m not aware of the logic behind this project field that search is based on, also sorting by created date:

Could you please try to remove this sort and simply search for the Milestones, plus changing the value for the Type field into a lowercase, then give it a try again.

However, if you still experience the same or any other issues, we could take a look into your application.

Hope it helps.

Hi Alex,
Ok, great. Let me try this out and see what happens.

Hi Alex,
I cannot for the life of me figure out what my issue is and how to solve it. Would you be willing to take a spin through the application and see if you can find the issue?

Hi @jasontrueblood,

Please go to Settings - Collaboration tab within your editor. Add our [email protected] account to your collaborator’s list. Also, please tell us your app name and page name where this problem occurs on test.

Note: avoid the warning message regarding plan, as we are an agency and you can easily add us to your collaborators.

We’ll investigate it inside your app and get back to you with a feedback asap.

Thanks :pray:

Hi Alex,
I have provided access to the app via the email you provided. The Gantt chart is located on the page titled “project details page” in the “Timeline popup”. Thank you so much for your help.

Hi @jasontrueblood,

Thanks for sharing your app. We have tried to replicate the issue, and I think we had some success. Unfortunately, it is not displaying the charts because of the optional fields that seem to be required to fill in, even though it is not mandatory based on our docs. Please let us investigate and fix the errors, then I’ll get back to you with an update asap.

Meanwhile, it seems that everything is configured properly inside your app, but could you try to fill in these fields as well:

With appropriate data from your Bubble database, so it might work in case it is not that of a problem for your application.

Thank you in advance for patience. :pray:

Hi @jasontrueblood,

I’m reaching out with a small hint. Try just to select the appropriate fields for Task User/Parent/Depend On so they are not left empty, but you don’t have to necessarily fill in your data records (milestones) with this information. Meanwhile, our team is already checking on this use case and I’ll come with an update asap.

Thanks

Hi @jasontrueblood,

We’ve fixed the plugin in regards to these optional fields. Now, you can leave them blank in the elements settings and it will display the gantt chart with your milestones. Please do upgrade the plugin to the latest version, refresh your app and give it a try!

Thanks