Templates Plugins Courses

Getting this "technical error" message on the Marketo template

Hi! I’m new here. When building my marketplace using the Marketo template, I am getting an error that “Sorry, due to a technical error we are unable to register sellers at this time. Please try again later.”

Picture attached. What could be causing the error? Do I need to enable something on the site?

Thank you!

Hi, @nrovall
Thanks for reaching out.

It is required to create a Stripe account and configure the API keys for your template in order to make it work.

Please check this documentation https://docs.zeroqode.com/templates/marketo-marketplace-like-amazon-template/setup-guide where you can find the necessary instructions. Make sure the template has been configured properly, then give it a try again.

Hope it helps. :pray:t2:

Best,
Gulce

Hey Gulce! Thanks for the reply. I enabled Stripe but am still getting this error message? I noticed I still have some of the following red boxes showing in my Admin Workflows. Should I manually delete these?

Red Boxes from the Guide:

Similar Boxes in my Admin Workflow:

Hello @nrovall

Thanks for your message.

It could happen because some settings in the Stripe plugin are not set up properly. Please make sure that all the Stripe Keys in the plugin setting are set properly, especially the Client ID, and give it another try. The Stripe plugin settings you can find in the Editor, tab Plugin-> Stripe Plugin. Here is a guidance 5 on how to set up the Stripe Keys.

Also, it is quite useful to check out our forums for some good insights:
https://forum.zeroqode.com/search?q=stripe%20category:6

In case you still see this error, can you please share with us the screenshot of your browser console, when this error appears?

As for admin rights, yes you need to remove them manually, and then select any user from your database, grant the Admin Rights by setting Admin filed to “yes”, and only this user will be able to have access to the admin page. Find your user in App Data > Users tab and change the admin field to “yes”. Here:

Hope it helps. :slightly_smiling_face:

Best,
Gulce

Hi Gulce,

Thank you for your reply.

I made the following changes but am still having issues.

  1. I manually deleted the “GroupUser” items from the admin workflow page.
  2. I double checked my Stripe test keys and re-entered them.

Here is a screenshot of my browser console.

Is it possible to get on a call with support to sort this out?

Thank you.

Nat

Hi @nrovall
Thank you for the screenshot.

Unfortunately, we don’t provide support services via phone/online calls. Apologies for the inconvenience :pray:

Regarding the Stripe error, it might be a bug on the Bubble side. Kindly ask you to record a video, where you are reproducing each step? It will help me to analyze the appeared error. And, for the screencast recording, let me please suggest using the Loom tool.

Also, please follow the first option we mentioned in the documentation for admin access. Namely, go to database → App data → All variables and modify the Access from “no” to "yes”. Here is an example:

Summary

Looking forward to your reply.

Best,
Gulce

Hi Gulce,

Here are two videos showing me making the required changes, then previewing the admin page and still not having full access.

I submitted a test payment through Stripe and received confirmation that my test payment went through so I do not think it is an issue with Stripe.

I noticed that in the All Variables > Yes video, it says “Created By (deleted thing)” at the right.

Maybe that is causing the issue? Let me know what you think.

Thank you!