Templates Plugins Courses

Gmail plugin error


#1

hi, I just installed gmail plugin and I’m having a issue to make it work.
this is error msg when i click “mail send” button

The service Gmail - Small Business - Send Text Email just returned an error (HTTP 401). Please contact the plugin author directly for feedback. Raw error: { "error": { "errors": [ { "domain": "global", "reason": "required", "message": "Login Required", "locationType": "header", "location": "Authorization" } ], "code": 401, "message": "Login Required" } }

I wonder what’s the issue.
i set app ID/api and app secret from google cloud consol’s app client ID and app secret.
did i set up something wrong?

cheers


#2

Hello, thank you for reaching out!

Please go to the Library, search Gmail API and check if the API is enabled.

Also, please check if the mail that you are using for login is working on our demo page here. Please let me know if the API is enabled and the mail works.

Best Regards,
Alex


#3

Hi, Alex.
Thanks very much for the reply!

First of all,
I enabled Gmail.
Now I have this login page! which is good

however, when I logged in, this error shows up

And I tested your demo page as well. It’s same.

Login with your Gmail account
Note: Due to the demo page being unverified, some users may experience a Google Warning while trying to login with their accounts.
Once installed, the plugin will work as expected.

And this from your demo page,
once installed the plugin, it will work? What does that mean?
How can I make it work?

Thank you again :grinning:


#4

Hello @minnnn,

If you have a login page that means the plugin works. The error appears because of the Google Apps Verification process. On our demo page, you can click on Advance and allow the app to authenticate you to see how the plugin works.
Once the plugin will be installed it will work, to get fix the error you have to verify the app. This is a requirement from Google. You can find the verification process described here: https://support.google.com/cloud/answer/7454865?hl=en

Best Regards,
Alex