Templates Plugins Courses

Google Calendar Plugin


#1

Hi,

I’m trying to implement the Google Calendar plugin but am having some problems. I can successfully authenticate with Google and have it send me back to the Bubble app but it’s not asking me to consent to having the calendar managed despite me having the Calendar API enabled, etc.

Is there a step by step guide available on how to configure everything that’s needed?

As it stands, it doesn’t return any errors when I attempt to populate a repeating group with the names of available calendars, it just doesn’t retrieve anything.

I’m guessing this is isolated to the consent being given when authenticating but I’ve tried revoking the credentials and re-adding the user but to no avail. Is there a log somewhere I can access which contains the API calls so I can at least see if it’s not allowing access to the calendar? Or, what settings do I need to change in the Google API console to make this work?

Any help is appreciated.


#2

Hey Scott, i suggest checking this guide https://forum.bubble.is/t/how-to-google-services-client-id-secret/18845

make sure everything is configured correctly, because the plugin is supposed to work correctly.
Thanks!
Levon Terteryan
Founder @ Zeroqode & Bubblewits

let’s stay in touch on twitter!

zeroqode-for-web-160x120

Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services


#3

I have no doubt it’s something I’m doing (or not doing as it were) rather than the plugin.

Cheers for the info, I’ll have a look.


#4

As suspected, it was something I was doing.

In my “login/signup to google” workflow I hadn’t selected the Google Calendar API as the method for logging in. This meant that Google never granted consent to “manage calendar” to the authenticated user.

I will update the app to be a little more robust and allow it to add that consent in at a later date.


#5

Thanks for the update Scott!

Levon Terteryan
Founder @ Zeroqode & Bubblewits

let’s stay in touch on twitter!

zeroqode-for-web-160x120

Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services


#6

Hello-

The google calendar plugin is not working in the mobile app environment but worked when I tested in a browser on the mobile phone. See attached message - seems it says Google updated their requirements in 2016 and perhaps this plugin hasn’t been updated since? see attached image

Thank you!!


#7

That’s true we haven’t updated the plugin for a long time but we have published it initially in 2017 so we may have never supported this format. Can you share a link to their updated requirements so we could take a look if we can implement them?


#8

updates on oauth:

calendar auth specifically for google calendar:
https://developers.google.com/calendar/auth

Let me know if this helps. Thank you!


#9

Well they simply say they won’t be supporting oauth in webviews any longer and suggest a mobile browser to be used instead. Not sure what we could do here


#10

Thanks for checking that out! I think I’m confused because isn’t a mobile browser being used when you’re on your mobile phone from within the mobile app?


#11

yes, but they can see that somehow and decided to block it for some reason. So it only works when you really open a browser


#12

Ok, if that’s truly the case it would be awesome to somehow include that in the plugin notes as I’ve spent quite a bit of time getting that connector to work and that would have saved a ton of $$ upfront had I known that. Thank you!


#13

Hello I am trying out the Demo linked directly in the plugin page and it seems it is not working. I can connect and the calendar list is populated with the right calendars, however when I try to create an event, I get the error shown below:

Here is the complete error:

2018-11-18_15-25-18


#14

I have fixed the issue, and it works fine now, please retry @malife


#15

That worked. Thanks @levon!


#16

Having an issue with the google consent screen repeatably showing even after the initial consent is given.

Steps to reproduce:

  • Log in user with google calendar plugin + offline
  • User grants consent
  • App + plugin works perfectly
  • User log out
  • User returns and does log in
  • User presented with google consent screen screen again

I am under the impression that once you have granted consent to an application that is remembered by google until you explicitly remove the permission in your google account.

What am I doing wrong or missing? Thank in advance for your help.


#17

are you using the free version of this plugin or the paid version with Offline access? That’s in fact the only difference between them, with paid (offline) version of the plugin users’ consent doesn’t expire within 1 year, while with the free version users need to give consent every 50 minutes or so


#19

No I am using the latest of the paid version that has the push notifications you made for me. Simply have a login action using google offline and a default user log out action

Mike


#20

Hi Mike, sorry didn’t realize it was you.
maybe you need to authorize your app with Google?


#21

@levon,

I am good there…it logs in just fine, just doesn’t remember that I authorized the app. In fact, I can not see the app as authorized in my google user account. I will PM you the shared development URL for you to try…