Templates Plugins Courses

Google place autocomplete - need help to Start


#1

Hi Zerocode team,

I just get started with the plugin and follow the steps in the doc : My google place API key is set up ; I have the autocomplete element with the ID of my input set up. ; all the boxes are well configured in the element. But When I type in the input , no autocomplete boxe with some autocomplete results appears. I can’t figure out why.

I m on a personal plan , and have other plugin like the customize scroll bar ( zerocode) and a search & autocomplete on the page.

After inspecting with the debugger, using the same workflow than in your demo, I got this error message from bubble :

Thanks a lot by advance for your help.

To go further , I also have two questions : is it a way to get the place time zone ? Directly with the plugin or with an eazy workaround , based on the data extract with the plugin ?

The other one is an issue : In your demo page I type one text « la clairiere » which is a french bar/ music event, and the only way to ger this result was to type « la clairiere bar ». But when I enter the exact adress of the place , it returns no result.
Is it a bug with some place ? I thought that the exact adress should return the good place in every cases.

Thanks again for your answers,

Best regards


#2

Hello @szczepaniak.nto,

Considering that based on your description everything was set up accordingly could you please add [email protected] as collaborators to your app and specify the page where the plugin is used? It will allow finding the cause of the problem from its roots. Also, while adding us as collaborators please disregard the notification about the limitation of your plan. We are an agency and can be added as a collaborator on apps from any plan.

Unfortunately, the plugin doesn’t have this functionality and I am afraid we cannot provide any easy workaround that can generate a timezone using current functionalities of the plugin.

The plugin requires the address to be imputed in the format of google so if the format is correct the results will be returned. As you can see on the attached print screen the plugin does return the place when the address of “la clairiere bar” was searched.

Best Regards,
Alex


#3

Hi @alex.grimacovschi,

Thanks for answering ! I just add the adress you said as collaborator, I recreate my test of the plugin in the page “test-zerocode”. I just precize that my Google API key has no restriction yet and contains the timezone API and google places API (maybe it misses some).

Regarding the timezone, i wonder if it could be possible to get the timezone ID from the full adress of the place which should be a geo_adress ?

And for the last one : I did know that the result appears when entering “la clairiere bar”, my concern was more about the user should not think about typing “bar” after the name, so i wanted him to type the adress instead of the name (sorry if i was not clear). But by typing the adress, no result return, as the screens below :


#4

Hello @szczepaniak.nto,

We have checked your app and we noticed you don’t have the map added to the page. Because of that, the plugin was showing the error. Please add the map with the following settings.

No, unfortunately, the current functionalities of the plugin do not allow that.

The format of the searched location is defined by google requirements as we are using their API. We cannot change that format wile using this plugin the format of the searched location should be as defined by Google. In case the searched location address has “bar” then it has to be written in the search bar. Regarding the additional searches that weren’t processed the logic is the same, the address should match google format.

Hope that makes sense!

Best Regards,
Alex


#5

hello @alex.grimacovschi,

thanks for your quick answer. I added the map with the correct settings as you said, and replicated the workflows of your demo page with still no success. Because the plugin deals with the map display, I wonder if my issue could have something to do with my current Google API services from map. Currently, my API key is link to two services : google places and google time zone. Does the plugin need other API connections to work properly ?

I thought that it was possible to use the plugin whithout displaying the place on the map, as we could think with the box “map element present on page?”. But when I unchecked this box, the input was not working (disable), displaying a little “!”. So I wonder, is the plugin able to return place info whithout the map on the page ?

In my case it doesn’t work right know whatever the map is here or not. Can’t wait to find the solution and use this cool plugin ! thanks again for your help

If you need to have an other look, the support team is still invited as collaborator

Nico


#6

Hello @szczepaniak.nto,

We have checked your app once again now the error seems to appear because you didn’t enable Directions, Places API in Google Cloud Platform. Please check the documentation and make sure everything is set up accordingly.

Yes, it should be possible but unfortunately, we found a bug related to this functionality. As a workaround please keep a map on the page, in case you don’t want to have it displayed just make it 1x1px. Meantime our developers will work on fixing the plugin. I will let you know when the updated version with bug fixes will be published.

Best Regards,
Alex


#7

Hey @alex.grimacovschi,

indeed i didn’t enable the direction API ! But back to my Google console I enable it without success. To be sure I enable all the API like map javascript, distance etc to check if it could come from this. I still get this error message :

The plugin Fastest Google Places Autocomplete / action Get Place Details a Google Autocomplete threw the following error: TypeError: Cannot read property ‘PlacesService’ of undefined
at Object.c.getPlaceData (PLUGIN_Fastest-Google-Places-Autocomplete-initialize–Google-Autocomplete-.js:5:255)
at eval (PLUGIN_Fastest-Google-Places-Autocomplete-element_action–Google-Autocomplete-Get-Place-Details-.js:6:16) (please report this to the plugin author)

I also tried to reset and paste a new API key in the plugin… having no custom domain right now i didn’t put the geocode or google map API in the settings of the app, as it is ask if the app is on a custom domain, and if the purpose is to use the map.

Great I think that this fix could be really usefull in term of limiting the SKU number having not the map displayed, I guess ? anyway, still in trouble with this error,

Thanks for your next answer mate !


#8

Hello @szczepaniak.nto,

Could you please check the section “General Services API Keys”?


In that section also, have to be added the API key.

Best Regards,
Alex


#9

HI @alex.grimacovschi

It finally works ! was not sure about to add the key in this section because i didn’t plan to use the map. I will keep an eye on the updated version with the bug fixed on the “disabled map” option :). So cool to see it works properly !

Thanks a lot for your help and reactivity !