Templates Plugins Courses

Google Sheets & Charts (Service) plugin: unexpected error


Hi, guys.

I’m calling any action from that plugin and have unexpected error.

  1. I installed Google Sheets & Charts (Service) plugin. Did it 4-5 times while testing - delete and install again.
  2. I set up Service Account and obtained Service Account Keys. Did it 4-5 times while testing.
  3. I added the keys in Bubble Google Sheets plugin. Did it 4-5 times while testing.
  4. When i try to call any action from that plugin (for example Create Spreadsheet, but it’s the same error on ANY) i always have “General error. Sorry, we have encountered an unexpected error.”

My project is almost empty - i coundn’t have problems with other functionality. I checked live demo in bubble in detail. So, my questions are:

1.I have no idea how to find the reason of that error. Can you help me?
2. I didn’t understand the concept of Sheets Data Maker and Sheets Data Parser elements.


Hello @silin,

Thank you for reaching out!

The issue may be caused by the settings of the plugins, could you please check if you did everything as specified in the documentation regarding Obtaining Service Account Keys.
Please take special attention to step 4 and the editing of the key. If this will not help, please add [email protected] as collaborators to your app and we will check the issue.

Regarding Sheets Data Maker and Sheets Data Parser we will develop a guide and will share it. It will take some time but once it will be ready I will notify you.



Hi, Alex.

I found my mistake and possible bug. My experience may be useful for other users of that plugin.

1. Careful with text editors.
My text editor (Atom) was adding invisible for me spaces at the beginning of every line. Other users of that plugin - be careful with that.

2. Editing keys possible bug
I found one pattern. If private key has originally generated “=” or “==” in the endings - it doesn’t work. I tried many keys, i always deleted “=” - and did it in different ways. Because in docs you write to change it with <-Enter. For “\n” that’s obvious, but for “=” it’s not 100% clear should i change it with <-Enter or just delete. On screenshot in docs It was deleted. So anyway i tested all possible ways.

Sometimes original keys doesn’t have this sign “=” or “’==” in the ending. These keys are working. Others are not.

3. Errors explanation
If you have unexpected error - problem with keys or email entered in plugin settings. If you have other errors - you have successfully connected to your service account.

4. Plugin works! It’s cool.
I tested only some calls, not everything. It’s working good. I know how hellish is google api documentation and auth, so thanks for your work :slight_smile:


Hello @silin,

Glad to hear that the problem was solved. Thank you very much for sharing your experience!

We will check for the possible bugs with the key and will update the documentation accordingly.



Hi again)

I have an issue:

when i try to get data from sheets using ‘Get Sheet Values (Numbers)’ the result is rounded to integer and i can’t get decimal numbers.

I checked the flow and i think it’s not on the bubble side. I checked recording in bubble’s database and direct showing the result on a page.

I can get decimal numbers using ‘Get Sheet Values (Text)’ but i can’t use the result in calculations.


Hi @silin,

We will check this issue and will do our best to provide a solution ASAP! I will keep you posted in this regard.

Best Regards,


Could you please check if you are using “.” or “,” it is a pretty common issue with excel? We tested on our side and if it is used “.” the plugin provides decimals of the number.


Yep, i was using “,”. With “.” it’s ok. Thanks.


Hello @silin,

If you like our plugin you can rate it by going to Plugins tab in Bubble editor. Find the plugin by name and it give it as many stars as it deserves :slight_smile: The more feedback we get, the more motivated we are to make things better in Bubble.

Thank you in advance!