Templates Plugins Courses

Having issues setting up apple sign in plugin

I’ve followed all the steps outlined by the plugin documentation but the login process still doesn’t work. On signup the user will always be redirected to the error page. The error seems to be a 400 error

Plugin action Apple SignIn - Authorize User error: 


Error: Outer Error (see above for inner error)
    at Block.wait (/var/task/u.js:420:34)
    at Object.async_fn [as async] (/var/task/index.js:316:35)
    at eval (eval at build_function (/var/task/index.js:86:21), <anonymous>:50:20)
    at /var/task/index.js:349:23
    at run_fn (/var/task/u.js:594:18)

Thanks in advance

Hello, @osose
Thanks for reaching out.

The error 400 means that the user is not authorized in the system and the plugin just can’t find your application.
In order to check this moment, can you please share the screenshots of your Redirect URLs from the Apple Console and from your application ( Button and Backend Workflow)?

It will help me to understand that exactly is not correct on your side.

Looking to hearing from you soon.
Best regards,


image
image

Hello, @osose
Thanks for the screenshots.

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide me a link to your application? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email support@zeroqode.com

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Regards,

Hi @Ecaterina , sorry for taking so long needed to get confirmation from customer. I’ve been to add you as a collaborator to the app. Thank you

Hello, @osose
Thanks for the provided access.

Unfortunately, with limited rights, I’m not able to check all the required points (for example Server Logs, which we need for checking the error code).

We will analyze your application deeper and will revert with an update ASAP.

Best regards,

Hi @Ecaterina
The rights to app have been changed. Thanks

Hello, @osose. Thank you for your patience.

We have carefully investigated your setup and we presume the root cause of the error is the user authorization step. Namely, your Private Key. Would you please try refreshing/recreating it from the very beginning? Please be careful, since any typo/excess symbol can cause the error.

The 9th step in this guide:
Setup Guide (zeroqode.com)

Thanks!

Hi @kate Thanks for the help so far. We been able to recreate the Private keys. But it still doesn’t seem to work

Hello, @osose
I’m sorry to hear it :pray:

It seems like you removed our email from the list of collaborators, so we can’t access your Editor.
Can you please add us there once again?

Unfortunately, without adding us to the list of collaborators, I can’t continue an investigation.

Looking to hearing from you soon.
Best regards,

Hi @Ecaterina

Thanks for the help so far. You’ve been added to the app as an administrator.
My regards.

1 Like

Hello, @osose
Thank you!

I will continue investigation of your app with our Development Team. I will do my best to speed up the process.

Best regards,

Hello, @osose
Thanks for your patience.

After checking the new keys and your application with our data, it was detected that some of your settings are still incorrect, and I’m talking about your Apple settings.
In order to speed up this process and help you in the nearest time, we propose you to give us access to your Apple Console.
It will help me to check all the links for Redirect, the difference between your domains in the app and your console.

Please let me know if it is possible to provide us your credentials? Immediately after accessing your console, I need to receive the TFA code.

Looking to hearing from you soon.
Best regards,