Templates Plugins Courses

Issue with date/time convertor plug in


#1

Hello,

I am trying to convert a date/time from Unix code into a date that Bubble can understand…

in a workflow, I use the “convert date/time convertor A”. I input the unix date and I succeed to have the output in text format but nothing in the date format…

is it a known issue or am I doing something wrong ?

Thanks for your help,
Arnaud


#2

Hi Armaud,
If I understood properly, the issue is hidden in the plugin returned value. The plugin currently returns “list of dates”, as you can covert multiple values at the same time. So in case you have only one date to convert, simply add “:first item” as on the attached image.
Please let me know about the results.

image

Regards,
Karel


#3

Hello Karel,

thanks a lot for your help.
I already put the :first item stuff…

Let me explain a bit more my issue :

  1. I add the convertor in a workflow :

  2. Then I change the thing table
    cf here the 2 screens :

But in that case the anniversary_date is empty.

BUT
if in the same process I save Date/timeconvertor A’s TEXT format!first item into a text field, I have the date I am looking for (but in text format) !

Do you see what I’m doing wrong ?

Thanks and best regards,
Arnaud


#4

putting the image in bigger format (hopefully :slight_smile:)


#5

Thanks Arnaud,
We have found the issue you have referred and fixed it.
Please update your plugin to the latest version, and it should be just fine. We have also added this feature to our demo page, so you can see how we settled it on our end.

Regards,
Karel


#6

Hello Karel,

thanks a lot for your very quick answer.

But this is still not working…

In your exemple code, if you type a unix date code : 1537543443

then click on “save it to the database”

You will get an empty ‘date’ field.

Please, could you also check this one .

Thanks,
Arnaud


#7

Sorry about this Arnaud,

I have forgot about one bubble issue, where is not recommended to use plugin data (like save into DB) in the same workflow as where you have updated the plugin. It’s hardly recommended to firstly update the plugin data and then in another workflow work with them.

For that reason we have added to our demo page "schedule custom event’ with delay “1 second”, where we save our date in database separately. That way we simulated two workflows, but in the best practice, we had to use two actions (like click 'Button A" to update plugin and click “Button B” to save it).

We have informed bubble about this issue some time ago, so we will send a reminder to see what’s the status.

Regards,
Karel


#8

No problem Karel…

But this is still not working for me.

When you put the input value (in my case in unix format : 1537543443) inside your module convert Date/time (in the workflow), then there is no output in date format…

Best regards,
Arnaud


#9

@a.duclap06
Can you please add our developer "[email protected]" as collaborator, or share with me (in private message) access to your app, so we can have look on your solution?
We have run few other tests on our end, but there seems no issue.
Regards,
Karel


#10

OK, Karel, can you provide me with your email adress so I can reach you in PM ?

Also, I am reluctant to give access to my apps as there are all the credentials to my stripe account and other things…

Is there a way (without paying) I could create an other apps with your plugin so I can copy/paste what I’ve done in my apps ?

Thanks,
Arnaud


#11

Hey Arnaud,
let me reply here
if you create a template based on an app then you can install any paid plugins there (note though, you won’t be able to use such an app for production, just to avoid the temptation :))
so you could do this to replicate your configuration and settings and then simply make the app public so anyone can edit and share the link with us.
thanks
Levon


#12

Hello Levon,

This is a great idea but in the meantime, I’ve seen you upgraded the plugin to 1.3.0 (I was testing on 1.2.0) and this is solving my problem !

Thanks a lot for your great and fast technical support.

Best regards,
Arnaud


#13

Thanks Arnaud, glad the issue has been solved :slight_smile: