Templates Plugins Courses

Issue with Docusign Extended

I’m having issues using Docusign Extended plugin.

I need to insert a lot of dynamic variables into the JSON to send an enveloppe , and the plugin fields doens’t let me do that easily.

So instead, I’m trying to put the json in a state and use the state from the plugin action.
CleanShot 2021-11-05 at 09.38.50

Putting the json directly in the plugin action field will work, but when reading the same json from the state, it triggers an error:

{
  "errorCode": "INVALID_REQUEST_BODY",
  "message": "The request body is missing or improperly formatted. Invalid property identifier character: \\. Path '', line 1, position 1."
}

I tried doing a console.log on the json coming from the state and it appears to be valid.

Any idea why the plugin is not accepting the json when not inputted directly in the actiel field?

I forgot to add that I’m generating the state using Arbitrary text:

CleanShot 2021-11-05 at 09.40.58

Not even inserting anything dynamic.

Hi @kbernard, thanks for your messages, and apologies for the delayed reply (due to the weekend).
The mentioned above issue might be related to the fact that the state doesn’t have time to initialize properly with included values.

In case you have a single workflow responsible for state setup and envelope sending, allow me to recommend separating these two events into two workflows.
For example, in one workflow you set the state, and the second workflow (with envelope sending) is triggered only when the state value is not empty.

Hope it helps. In case the issue will persist, please let me know and share a screencast with the description of all related workflow setup and use case flow.

Regards,

Hi Serg,

Thanks for replying back. I don’t think it’s related to the state not being set quickly enough.

I can replicate the same error by putting the json in a regular input field.

I can’t get the plugin to work unless the json is set directly in the plugin json field.

I’ve setup a small demo, this time using regular input field instead of using the state.

Hi @kbernard, thanks for the provided video.
Please tell if the used plugin is up to date and you are using the latest version.

Looking forward to your reply.
Regards,

@Serg We use v1.5.0 which seems to be the latest version.

Hi @kbernard, thanks for the provided reply.
For a better understanding (what could be the cause), would it be convenient for you to add our [email protected] as a collaborator of your app?
That will allow us to check what’s wrong with your setup and test it out in our workspace.

Enter your Bubble editor page → Settings → “Collaboration” tab → Invite a user (email).
(Note: disregard the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.)

I will check your setup and do a few tests in an attempt to find the root cause and help you fix it.
In case it is ok for you, please let me know.

Regards,

I’ve added you @Serg to my test App, you can check the page:

Hi @kbernard, thanks for the provided access.
In a short time, we will push a plugin update that should fix the above-mentioned issue.
Once the update will come to live, I will let you know asap :slightly_smiling_face:

Regards,

Hi @Serg ,

I tested the new update, v1.6. It no longer show the javascript alert, however the same issue remains.

If I insert the JSON directly in the workflow step, it works. If I use the json read from the Input element, it doesn’t work.

You can test again, I’ve added a step to output the result/error into a text element.

Hi @kbernard, thanks for your feedback.

Please check if the access to [email protected] is still allocated, so far it shows:

Looking forward to your reply.

Should be fixed now, sorry!

I suspect that when the json is read from a field, it’s formatted as an invalid json string. I can’t validate since I can’t inspect the payload being sent to docusign in the body since it’s server side.

Hi @kbernard, thanks for providing access.
Allow us to check once again, and provide feedback asap.

Thank you for understanding.
Regards,

Good morning @Serg , any update for us?

Hi @kbernard, sorry for the delayed reply :pray:

Our developer team checked the plugin work within your application. With correct JSON it works properly (both directly and from input).

To avoid errors related to JSON, please use the examples from the official DocuSign documentation: Envelopes createEnvelope | REST API | DocuSign

Here is also a workable example:

{   "recipients": {     "signers": [       {         "email": "[email protected]",         "name": "Tester",         "recipientId": 1,         "tabs": {           "signHereTabs": [             {               "xPosition": "100",               "yPosition": "100",               "documentId": "1",               "pageNumber": "1"             }           ]         }       }     ]   },   "emailSubject": "email subject",   "documents": [     {       "documentId": "1",       "name": "blank1.pdf",       "documentBase64": "JVBERi0xLjcKCjEgMCBvYmogICUgZW50cnkgcG9pbnQKPDwKICAvVHlwZSAvQ2F0YWxvZwogIC9QYWdlcyAyIDAgUgo+PgplbmRvYmoKCjIgMCBvYmoKPDwKICAvVHlwZSAvUGFnZXMKICAvTWVkaWFCb3ggWyAwIDAgMjAwIDIwMCBdCiAgL0NvdW50IDEKICAvS2lkcyBbIDMgMCBSIF0KPj4KZW5kb2JqCgozIDAgb2JqCjw8CiAgL1R5cGUgL1BhZ2UKICAvUGFyZW50IDIgMCBSCiAgL1Jlc291cmNlcyA8PAogICAgL0ZvbnQgPDwKICAgICAgL0YxIDQgMCBSIAogICAgPj4KICA+PgogIC9Db250ZW50cyA1IDAgUgo+PgplbmRvYmoKCjQgMCBvYmoKPDwKICAvVHlwZSAvRm9udAogIC9TdWJ0eXBlIC9UeXBlMQogIC9CYXNlRm9udCAvVGltZXMtUm9tYW4KPj4KZW5kb2JqCgo1IDAgb2JqICAlIHBhZ2UgY29udGVudAo8PAogIC9MZW5ndGggNDQKPj4Kc3RyZWFtCkJUCjcwIDUwIFRECi9GMSAxMiBUZgooSGVsbG8sIHdvcmxkISkgVGoKRVQKZW5kc3RyZWFtCmVuZG9iagoKeHJlZgowIDYKMDAwMDAwMDAwMCA2NTUzNSBmIAowMDAwMDAwMDEwIDAwMDAwIG4gCjAwMDAwMDAwNzkgMDAwMDAgbiAKMDAwMDAwMDE3MyAwMDAwMCBuIAowMDAwMDAwMzAxIDAwMDAwIG4gCjAwMDAwMDAzODAgMDAwMDAgbiAKdHJhaWxlcgo8PAogIC9TaXplIDYKICAvUm9vdCAxIDAgUgo+PgpzdGFydHhyZWYKNDkyCiUlRU9G"     }   ],   "status": "sent" }

Also, to check the status of the sent message, please change the setup accordingly (now it is not correct):

for reference, you can use the corresponding workflow from Demo Editor page:

Hope it helps. Please let me know if I can help with anything else related to our plugin.
Regards,

Thanks for the help @Serg

1 Like

@kbernard you’re welcome :wink:

If you like our plugin you can rate it by going to the Plugins tab in Bubble editor. Find the plugin by name and it gives it as many stars as it deserves :slightly_smiling_face:

The more feedback we get, the more motivated we are to make things better in Bubble.

Have a nice day!
Regards,