Templates Plugins Courses

Issue with Encode/Decode plugin


#1

I am having an issue with the encode/decode plugin not saving correctly.

When I test it out by having text boxes showing what the encode contains (i.e. what will be saved) it is all fine, but then sometimes nothing gets saved.

I am wondering if there is some kind of time factor that you may be aware of that is causing a problem. It is as though the encoding isn’t ready to be saved an so it just saves a blank entry.

Hope you can help.


#2

could you share some screenshots of your current setup?


#3

It is tough to share screenshots as there are 6 tabs and each one contains a multiline text box and the encode/decode elements.

I think it might be pushing the encode/decode a bit too far, and not giving the plugin its chance to work its magic. I’m doing lots of tests and think I am slowly getting there.

Is there any way to force Bubble into not continuing until the encode/save process is definitely complete. I’ve tried inserting a pause, but there is no way for me to know whether the pause is long enough.

If there were a way to know the encode/save workflow is definitely complete I reckon I can get it fixed.


#4

After extensive testing (I’ve spent two days doing nothing else) there definitely seems to be some kind of speed issue either on the encode or the decoding Levon.

It is hard for me to pinpoint as sometimes it will work and sometimes when the page is loaded it turns out the data isn’t there. Unfortunately, it isn’t consistent so it is very hard to pin point where the issue likes, i.e. whether it is with the encoding, the saving of the encoded data, the decoding or the loading or the decoded data.

The reason I am pretty sure it is speed is that I have six multiline inputs and it almost always manages to save and reload 1, 2, 3 and 4, but often 5 and particularly 6 won’t get saved.

I have added lengthy pauses between the encoding of each one and that seems to work, but it is impractical to have a save routine that takes 15 seconds.

I am trying various conditions to only encode when certain criteria are met, but struggling to find a reliable solution. I will often find that out of the 6 multiline inputs 4 of them won’t load anything even though something had been previous stored (and loaded successfully). It is as though the encode process hasn’t finished and so when it is saving the contents of the encode element there’s nothing there so it is saving nothing, i.e. wiping out the data.

Hope you can help.


#5

Hello @Siddhartha
We’ve checked the plugin’s code and we didn’t find any time factor there. We assume that the problem may be caused by the used elements. To find out the real issue and the solution we will need to look at your app. Could you please add us as contributors or at least share with us the link to the app?


#6

I’ve PM’d you a video of the issues and a link to the editor page.

Hope you can help as until I can get this working reliably I’m at a standstill and I’ve been at it for five days now and everything I try seems to work some of the time, but not all the time, and clearly, it needs to work all the time.

Thanks for your help. Much appreciated!


#7

Hi, @Siddhartha

Thank you for providing additional information we will analyze it and will come back to you asap.

Regards,
Alex


#8

@Siddhartha
We checked all materials sent by you and find out that the issue is in the workflow logic. After deleting the action do every 2 seconds and adding decode result of step 2 the plugin works fine. Please see the attached video.

Hope this solution will help.
Alex.


#9

Hi Alex, did you get the DM I sent you earlier in the week in reply to this?


#10

Hi @Siddhartha,
Yes, we checked the video and all three messages from you before answering. If you have any additional or unsolved issues please let me know.


#11

Hi Alex, I don’t know whether you are getting the replies I am sending via my phone. I think you might not be as it seems you haven’t replied to them so I reckon you’re not seeing them.

What I asked in my previous was whether the solution you sent (with the video in) was reading the data from the previous step and not from the data type itself (i.e. what is stored on Bubble’s servers).

The problem I seem to be having is not with the encoding/decoding it seems to be with the writing and reading of the encoded data from the data type on Bubble’s servers.

Does that make sense. That’s why I’ve been at it for many days now.


#12

Thank you @Siddhartha. I got the idea.
We will update the plugin and will add a new event “Start when encoding is ended”. I think this will help you and also will be useful for other users. I will let you know when the plugin will be updated.
Thank you for understanding and sorry for taking so long.
Best Regards,
Alex.


#13

Hi @Siddhartha,

We updated the plugin and now additionally are available events: A Encode/Decode Done Encode and A Encode/Decode Done Decode.
image
I hope this will help to solve your issue.

Best regards,
Alex.


#14

Yes!!!

Thanks guys. It is now working perfectly using the events you’ve added. I think prior to that there were definitely some issues with regard to things not having finished (e.g. encoding), before the next thing was started (e.g. saving). This has fixed it perfectly.

And what I love about the events is at has made the whole workflow so neat an understandable.

I haven tried a decode event yet, but I don’t think I’ll need to as the problem never seemed to be decoding and displaying, but rather encoding and saving. But, I know it is there just incase.

I’ve also thoroughly tested the whole encoding process for the last few hours and, unlike before, there hasn’t been one single error. 100% perfection :slight_smile:

I’m using this on a page with over a dozen multiline inputs, but as all the event actions are individual workflows it now doesn’t matter whether there was a single input or a hundred inputs.

Love you guys :smile:


#15

Hello,

I am facing something similar but after several days can’t advance:

I want to load decrypted values from inputs from bubble database on page load.
When user clicks on button I want values to be encrypted and saved in bubble database.

Can you please help, as decrypted values from database do not load inside inputs.

Thanks
Manuel


#16

I’ve managed to make it work for one input. Do I have to add an Encode Decode plugin for each input? Is there any way I can encrypt decrypt all of the inputs in one go?

Thanks


#17

Hello @manuel-calero,

Yes, you are right for each of the inputs has to be added an Encode Decode element. Because the element can process only one field, encrypting /decrypting of all inputs with only one Encode/Decode element is not possible.

Best Regards,
Alex.


#18

Absolutely right. It took me a while to get my head around having to have one encode and one decode element for each field, but I have it working beautifully now. What an awesome plugin.