Templates Plugins Courses

justGage Plugin not working correct

Hi,

Im having trouble with this plugin after i purchased it. The problem occurs when i want to display more than one justgage item on the page - I have tried both setting up a unique ID and also tried to add a pause on page load but nothing is working. The justgage items show incorrect data ( it swaps places with each other) Please, can anybody help with this?

@peter5,

Apologies for the late reply :pray:

We have checked the plugin and it works properly if you assign the unique ID to each plugin element:

To help us understand what could probably cause your issue, can yo please share the details of your plugin element setup and the preview page with the enabled debugger (inspect mode)? A video record will be a great help too.

Thank you.

https://sundhedsaftale.dk/version-test/dashborad?debug_mode=true

Skærmbillede 2021-01-07 kl. 18.07.22|520x500

@kate where you able to have a look?

@peter5,

Yes, I have checked the materials you’ve shared, thanks! But, unfortunately, this issue is not reproducing on our side. :slightly_frowning_face:

Please make sure you have indicated the correct values in the appropriate fields? I can also recommend you to check our demo page setup (editor and preview):

Can you please try to recreate on your page the plugin element set up just the same way it is on our demo page? To make sure you have tried this option too.

I hope it helps :pray:
Regards,

@kate then I don’t really know how to use this plugin then…

I have a custom datatype called “Stresstest1” that holds a field called “score” the type of the field is “number” - I want to display that score. I have placed the justgage in a group with datasource “Stresstest1”. I use this exprression: “parents groups stresstest1’s score”, it dosen’t work and if i do it with “do a search” it does’nt work… please help me :sweat_smile: :sweat_smile:

@peter5,

Will it be comfortable for you to add our [email protected] email as a collaborator of your app? So we can take a look closer at your plugin setup and test it out in an attempt to understand why it does not work and in what conditions.

You can add out support account even if your current subscription plan is a Hobby. Also please indicate the page name where you have installed a plugin.

I hope to test it asap and help you with your issue :pray:

@kate I have added your support team :smile:
the page its on is, “fit” and “dashboard”

1 Like

@peter5,

Your Stress Test 1 > “score” column is empty. That’s why the plugin element was not displaying any data.

If you fill your Stress Test 1 > Samlet score column with some integers - the plugin element will display it on the page preview:


Please check.


Also I have changed a bit the Initial value field. With this setup it works well:

@kate Im sorry Kate, but it does’nt work (I deleted the entrys because I tried to solve it) Now i re-input some values “score” and it still doesnt display properly… Its swaps places on the “fit page”.
Please have a look again :pray: :pray:

1 Like

@peter5,

I guess it should be sorted now. If your plugin elements have different dynamic data resources - try placing them into separate groups. It should help:




Please check :slightly_smiling_face:

You are AWESOME!!! Now im gonna have a great weekend :heart_eyes: :pray: :pray:

1 Like

Thanks! And have a great weekend! :wink: :grinning:

1 Like

@peter5,

Oh, thank you too :blush:

If you like our plugin - feel free to give it as many stars, as you think it deserves. You can rate our plugin in the Plugin section:

Also, if you face some other difficulties - feel free to let us know. We will be glad to help :slightly_smiling_face:
Have an awesome weekend too!

@peter5,

If you like our plugin so far, feel free to give it a rate. We will highly appreciate your feedback in the plugin review section :blush:

Also in a case, if you have some troubles/questions with the plugin - reach out freely.
Take care! :slightly_smiling_face:

@kate Sure, I will do that :slight_smile: Please, if you could make som more plugins with different gauges designs that would be awesome!

1 Like

@kate Sorry Kate, but some how it doesnt work anymore… I have’nt changed a thing…

@peter5, hello again.

Can you please provide more details or access to your app again to let me check what’s wrong?

Thanks! :slightly_smiling_face:

Hi @kate, Have given you access again. It’s on the “fit” page that it doesnt load