Templates Plugins Courses

Map Plugin Hide Controls


#1

Hello, zeroqode community. I have purchased the map plugin and to be honest, everything is working fine. But I have purchased the plugin because I thought it was possible to hide controls on the map (I got rejected my app because using control-maps in webview) so I need to make it feel native as possible.

It should be very easy to hide controls just a true/false opt-in dropdown in the plugin instead of true by default.

https://developers.google.com/maps/documentation/javascript/controls#DisablingDefaults

Please, I know this is not an urgent update as I have readen in bubble forum another user asked for, but please add this feature so I can publish my app!!! I depend 100% on this. It will be worth to add this feature many people will use it!!

:pray::pray::pray: @levon


#2

Hello there, @c6648481 !

Thanks for feedback, we’ll definitely consider this however as you already know this is not a priority at the moment.
Thanks for understanding.

Best,
Dumitru.


#3

Any ETA for this feature? As said my app is based on this feature if this is not considered “priority” I’ll be moving to another plugin.

I don’t understand why something that simply can’t be added. It should take no more than 5 minutes. You can add it even as a beta update so not all users will be moving to this update, but you allow other users that need this feature to use it. I’m not asking for a complete re-build, I’m not asking for custom integration, I’m not even asking to add a custom feature.

I’m just asking to change in the plugin code
disableDefaultUI: false
to
disableDefaultUI: properties.fieldui

it won’t take more than 5 minutes.
Thanks.


#4

No updates at all, thanks for ignoring the message. Not being able to make an effort to do less 5 minutes-work changing one simple false into a plugin property. Very disappointed.
Now I know where to buy and where not.


#5

Hello, @c6648481

I understand that not seeing a response may look like ignoring the message or the request, it is not like that. I hoped that’s understandable, however as I said we were not prioritizing this feature.
I’ll check with the team, in order to get it working on the feature asap.
Thanks.

Regards,
Dumitru.


#6

Hello @c6648481

Thanks for patience and understanding. We pushed the update to live, with the changelog:

  • Minor improvement (Was added toggle to disable/enable on screen UI)
    Please update to latest version, refresh the app and give it a try.

Best,
Dumitru.