Templates Plugins Courses

Mapbox plugin error

Hi! I implemented the Mapbox plugin successfully on my application. It worked very well until 2 days ago when it simply stopped working. Mapbox element no longer loads the map.

For example, I add the Mapbox Element to blank page.

When I run preview on bubble, this is all I see.

I have tried uninstalling and reinstalling app. I also checked my mapbox account. I am not over the free API call limit and have not changed any settings from when it worked a few days ago.

When I inspect the element, the map still recognizes my current coordinates but is not displaying the map

Hi @delin9, thanks for reaching out.

We’ve checked the plugin functionality on our end, and it works well.

I’m afraid, we can not reproduce or investigate this issue without more info. Can you please describe this case in more detail?

Please attach all the necessary info like:

  • error screenshots from the debugger and opened browser console;
  • the preconditions (related element settings and workflow), for reproducing this issue;
  • Loom video record of reproducing your issue + how and when you receive an error, etc.

This information will help us to investigate and resolve your case.

Thank you for understanding.

Regards,

I had the exact same issue on two different apps where the preview would show with only the controls and a beige background, no map. In private browser sessions it worked as expected. Turned out to be a browser cache issue. Tested on Vivaldi and Edge browsers (both Chromium-based). Deleting the cache resolved the issue (could not pinpoint the actual item that was causing the problem).

2 Likes