Templates Plugins Courses

Multi-Uploader Rotating Images During Upload

When uploading certain images via iOS photo roll, the images will rotate in the uploader 90º causing incorrect orientation…

Seems to be happening on the demo page as well. Is there a known workaround?

Hi @joshhowardla,

Thanks for reporting. Unfortunately, this issue is not reproducing on our side. To identify the possible reason for this issue, could you please share more details, like:

  • the exact steps to reproduce this issue
  • property editor settings of the plugin, as well as your app and workflows
  • the screencast of your iOS device, so we can see the reported behavior
  • browser and OS version of both devices where you develop your app and preview it on mobile
  • console logs

This way, we can have a better investigation then provide feedback on this matter asap.

Best,
Alex

issue: https://streamable.com/3e0l7y
plugin settings: https://streamable.com/8zp5en
plugin version 2.30
bubble engine v8
Safari iOS 13.5.1
Dev Mac 10.14.6 Chrome 84.0.4147.125

also occurring on iOS chrome

Hi @joshhowardla,

Thanks for feedback. Unfortunately, we are not able to reproduce this issue on our side. Could you please go to Settings - Collaboration tab within your editor and add our [email protected] account to your collaborator’s list. Also, please tell us your app name and page name where this problem occurs on test.

Note: avoid the warning message regarding plan, as we are an agency and you can easily add us to your collaborators.

We’ll investigate it inside your app and get back to you with a feedback asap.

Did you get this fixed? I’m having the same experience.

Hi @mickey,

Thanks for reaching out. Unfortunately, we haven’t managed to identify the reason for this issue yet, as we didn’t receive the feedback that can help us. But you can share the following ones:

  1. the exact steps to reproduce this issue
  2. property editor settings of the plugin, as well as your app and workflows
  3. the screencast of your iOS device, so we can see the reported behavior
  4. browser and OS version of both devices where you develop your app and preview it on mobile
  5. console logs

So we can investigate and provide working solutions asap.

Best,
Alex

Hey @alexandru.rusnac, @mickey, @joshhowardla

Were you able to find a workaround for this? The same issue is happening on a friend’s phone, but not on mine.

Cheers
Ambroise

Hi @ambroisedlg,

Thanks for reaching out. The image rotation issue still persists, unfortunately. However, it works properly with iOS v.14. We’ll certainly improve the plugin so it works with older versions as well, but the only workaround at this point would be upgrading to iOS v.14 or taking your picture in landscape, because it is only rotating in portrait mode.

Thanks for understanding. :pray:

@alexandru.rusnac thanks for the quick reply.

My iOS is version 13.7 and works fine, however my friend’s phone is iOS 14.1 and doesn’t work.

Only taking pictures in landscape mode is not a suitable option for us as we’re building a marketplace (users upload their items’ images via the plugin) - the UX would be a pain.

Is it possible that this issue arises because of the plugin configuration on my end? I activated the image crop and resize for example

Cheers
Ambroise

Thanks @ambroisedlg for feedback.

Perhaps we managed to fix this problem on our side. Could you please upgrade the plugin to the latest version, refresh your app and give it a try again!

Let me know if it works on your side. :pray:

Hey @alexandru.rusnac

Thanks a lot for your reply and for pushing the new version. Unfortunately after many tests on different devices, the issue still remains. Any ideas why?

Thanks for your continued support
Ambroise

Thanks @ambroisedlg for getting back.

Have you actually upgraded the plugin to latest version? We are testing it on our side and cannot find any issues with it, whether it is iOS v13.7 or v14.1, unfortunately. It should be all up-and-running with all devices and iOS versions.

You could try to clear cache and cookies, then give it a try again.

But if you still have same trouble, could you please provide more information on this matter like screencast to see the issue, as well as your iPhone model, and your app and plugin setups, so we can have the exact steps to reproduce it on our side, then see whether it is plugin related or not.

Thanks!

1 Like

Hey @alexandru.rusnac

I did upgrade to the latest version, but I kept the same element on the page (in fear of losing workflows obviously). I then deleted the element, put a new one and re-built the workflows and good news, it works great! Thanks a lot for your help and quick fix. Really appreciated.

Cheers
Ambroise

1 Like

Thanks @ambroisedlg for letting know!

I’m glad it is working fine on your side as well. If you like our plugin so far, could you please rate it by going to Plugins tab within Bubble editor? You can find it by name and give as many stars as plugin deserves. The more feedback we get, the more motivated we are to build great plugins!

Cheers

Hey @alexandru.rusnac yes I’ll do that happily - great plugin by the way!

Cheers
Ambroise

1 Like