Templates Plugins Courses

Need help with Agora.io bugs

How can I deal with a bug where a call is interrupted or only one person can’t hear the audio?

I am currently working on a group calling app with Bubble.

Only on certain devices, such as Android, or while speaking, the audio is suddenly interrupted.

But sometimes it is possible to talk without problems.

I’m using Zeroqode’s agora.io plugin and I’d like to know how to deal with this bug, even if it’s a way to look for a possible bug point.

Hello @16ec099z !

Thanks for reaching out! I’m afraid we could not replicate the issue on our side :pray:

Have you tried checking both connections side from users, also were the audio/video preferences set correctly in browser?

In order to understand the cause of the issue, can you please offer as many details as possible?

Like screenshots of you’re workflow setup, of errors, steps to reproduce the issue, browser/os versions, console.logs etc. so we could help you better.
Thanks for understanding :pray:

Regards,
Dumitru

1 Like

Hi. Dumitru,
Thank you for responding.

I already checked the connection sides, but it seems no problem.

[Service Specifications]
Video is completely off, and what allows multiple people to make a group call with audio only feature.

I’m not sure how to read Console.logs and haven’t been able to check them. sorry.

The red microphone symbol appears at the top of the browser on both the iphone and Macbook, so I think the device recognizes it correctly, but in some cases it doesn’t appear on the iphone. In all cases, the other side often shows it too.

Specific details of the error

1.I cannot hear the sound of the other person when I enter the room.

2.When you enter a room, the other person’s voice is audible, but the other person cannot hear your voice.

3.The other person’s voice is not audible when you enter the room, but your voice is transmitted to the other person.

  1. When more than 3 people enter the room, you can talk to 2 people but cannot hear the other person.

  2. There is a lag of more than 10 seconds even if the voice is audible.

  3. After entering a room and talking for a while, the voice suddenly disappears. At one time, I could talk for more than 30 minutes without any problem, but then it stopped suddenly.

  4. iphone 7’s Safari doesn’t even show the microphone mark at the top of the browser. I’ve checked the settings in the device, and iPhone 7 Brave is the same.

  5. In spite of these bugs, I can talk for more than 2.5 hours without any lag when I can talk.
    In that case iPhone 8 and Macbook Pro 2019, iPhone 7 and Windows 10 Laptop (model unknown), iPhone 8 and Macbook Pro 2019 and Windows PC case.

The same laptop (I currently using 2019Macbook Pro) may not be heard on different browsers.The two tested browsers were Safari and Brave, and Brave could not be heard when talking to the user after entering the same room with two browsers open in different windows.

The devices that have been found to have the bug are MacBook Pro 2019, iPhone 7, Samsung Galaxy, Windows 8 Laptop of unknown model

The iPhone 8 can be used without problems.
The current solution to the bug is to have the Agora Connector enter the room every second when entering the room.

Thank you,
16ec099z

Hi, @16ec099z!

Thanks for the details :pray:
We are already checking this issue. As soon as we have relevant info, I’ll get back to you.

Best, Julia.

1 Like

Hi, @16ec099z!

So, we have tested the plugin on different devices (iPhone, Samsung Galaxy, Google Oneplus, Pixel) and MacBook, Asus(windows 10) and didn’t manage to replicate the issues.
Could you please record your screen while using this plugin so could we see what is happening on your side? Loom is the best tool to record your screen. It would be super helpful if you could also open the console in order to see what error is appearing. To open the console on MacBook simply use Command + Space and on Windows - F12 .

Looking forward to hearing from you!
Best, Julia.

1 Like

Hi, Julia.
Thanks for addressing the bug.

I used Loom, which you introduced me to, to record a video of the bug.

My device is a MacBook Pro 2019, iPhone 7 and the other guy’s device is a MacBook Pro 2018 and his phone is an Android of unknown model.

I enter the room with two accounts and he enters with one account.

There is a bug in the display of room entrants, but please don’t consider it. The actual number of people in the room is three.

It is muted until the middle of the video, and when I unmute it when we enter the same room with separate accounts, only the computer is recognized for voice input.

As shown on the webcam, the iPhone 7 side is correctly recognizing the voice input device in Safari, but the other guy can’t hear the voice from the iPhone.

In general calling apps, the microphone on iPhone 7 works properly.

From the looks of it, it seems to be a bug related to the supported devices of agora.io plugin, but what do you think?

Here is what I recorded when these bugs happened.

Thank you,16ec099z

Hi, @16ec099z!

Thanks for the provided details.

As long as on our side everything works well, could you please try to replicate the workflow as it is on the Live Demo and give it another try?

Also, Agora gives info about platform limitations. Video encoding has the following known limitations that can influence the experience of use.

Hope this helps!
Best, Julia.

1 Like

@julia.minacova Hello.

Thanks for the advice. I tried to find the cause of these bugs, but the problem persists, so I’m asking again.

I’m assuming that the screen aspect ratio has no effect on the audio service this time since it is set to not show the screen.

We then verified that the same bug occurs in the live demo version as well.

As a result of repeated verification, we found that the bug seems to occur mostly when the version has not been updated, but sometimes the bug occurs even when the version is the latest and the device is supported.

I’ll share the bug and a copy of the workflow. (Conversation enabled :o:, Conversation disabled :x:)

iphone 8 version latest safari :o:

iPad air2 not updated :x:

iphone 7 version latest safari :o: Access from Japan

iPhone 7 version latest safari :x: Access from Taiwan

MacBook Air Chrome :o:

Chrome, GalaxyS10❌→Recover after Chrome latest update⭕️

iphone11 Maybe update to latest :o:

This is a copied version of an app currently in production. channel-normal is the page where the bug occurs.

Regards.
16ec099z

Hi, there!

Thanks for reaching out!

Let me familiarize with the all above and check. I’ll get back to you asap. Please be aware that due to holidays it might take time, so apologies for the delay in advance :pray:

Happy Holidays!
Best, Julia.

1 Like

Hi, @16ec099z!

Unfortunately, the issue is not reproducing on our side. The plugin itself is like a tool which connects or gives the possibility to make a call from your app using the Agora. But there can be other factors like Agora library, the internet providers and connection quality, devices and their restriction and others which are beyond our control.

Best, Julia.

1 Like

Hello.
Thank you for your advice. Since the workflow we sent you before was a copy of the original and did not have the Agora.io plugin installed, we would like to ask you for another verification and ask you some questions.

We are slowly figuring out the situation where the bug occurs.

Apparently:
PC/Mobile(iOS,Android)
Device update is not up to date
PC/Android.
A browser update is not up to date

Mobile:
Mobile: Audio doesn’t work in the in-app browser that can be accessed from social networking links.
The audio is interrupted when other apps are launched. (We hope to add a feature to enable background playback on mobile devices in the next plugin update.)

In all of these cases, Zoom and Messenger can communicate with the other party correctly, so it may not be a problem with the communication environment.

I would like to ask you to verify other situations that occur.

We have created a debug mode, so if possible, it would be great if you could actually enter the room to test and find out the situation where the bug occurs.
With multiple people using different devices, there are often situations where the voice goes through and situations where it does not.
If we can’t resolve this further, we are considering messaging supporters of the Agora.io SDK, and we would appreciate it if you could test this as well.

Regards,
16ec099z

Hi, @16ec099z!

Thanks for reaching out!

We have tested the page with different devices and people, and I’m afraid the audio issue is not related to the plugin itself as I mentioned previously. The best way will be is to write to the Agora.io, really hope they can help with troubleshooting related to the devices/browsers/OS.

With great hope that you’ll figure this out!
Best, Julia.

1 Like

Hi.
Thank you for your testing debug mode.

After asking to this thread, asking agora support. They responded that certain values are needed when this type of bug.

How could we call setLogLevel to set Debug level to collect log errors?

As far as we can see, pressing f12 doesn’t do anything of course, and it seems that the only way to allow this is on the Plugin(bubble) side.

Is there any way to enable this? If we can’t do it, could you enable it for us?

I will also share a contact image with agora support.


Regards, 16ec099z

Hi, there!

Thanks for the details. Need to check this out with the dev team. I’ll get in touch asap.

UPD: So, I have discussed with the dev team and we are going to implement this. I’ll notify you as soon as I have the relevant info.

Best, Julia.

1 Like

Hello.

Thank you. We’ll be waiting for your response.

1 Like